Permalink
Browse files

Merge pull request #14 from jmfee-usgs/java-1.8-compat

Document arguments required for XJC under java 1.8
  • Loading branch information...
2 parents df3352d + 35c1761 commit a6dd081fb4c5bfd58e41309c5d77e5a9b9f9c08c @jmfee-usgs jmfee-usgs committed on GitHub Apr 7, 2017
Showing with 9 additions and 0 deletions.
  1. +5 −0 README
  2. +4 −0 build.xml
View
5 README
@@ -20,3 +20,8 @@ Files:
Interesting Classes:
- gov.usgs.earthquake.event.Converter has methods for converting most formats.
- gov.usgs.earthquake.quakeml.FileToQuakemlConverter is an interface for parsers to create Quakeml from other formats.
+
+
+> NOTE: on Java 1.8+, you must run ant with ANT_OPTS for the XJC tasks to run
+>
+> ANT_OPTS="-Djavax.xml.accessExternalSchema=all" ant all
View
@@ -5,6 +5,10 @@
The MessageUtils project provides utilities for generating, parsing, sending, and receiving earthquake messages.
Using ant it should be fairly easy to build this project from source (try "ant jar").
+
+ NOTE: on Java 1.8+, you must run ant with ANT_OPTS for the XJC tasks to run
+
+ ANT_OPTS="-Djavax.xml.accessExternalSchema=all" ant all
</description>

0 comments on commit a6dd081

Please sign in to comment.