Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Calling utplsql.bat without parameters #110

Closed
alesana-san opened this Issue Nov 7, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@alesana-san
Copy link

commented Nov 7, 2018

Hi!

I guess it would be handy if CLI returned some help stuff instead of "Unknown command: 'null'".
Now I get that line when I call just "utplsql.bat" in a command prompt.

my utplsql-cli version: 3.1.2.271

@jgebal

This comment has been minimized.

Copy link
Member

commented Nov 7, 2018

Agree
Should provide a list of available commands like:

  • run
  • info
  • reporters
@pesse

This comment has been minimized.

Copy link
Member

commented Nov 7, 2018

I think it's a bug. Thanks for the finding.

@pesse pesse self-assigned this Nov 7, 2018

@pesse pesse added the bug label Nov 7, 2018

@pesse pesse added this to the 3.1.3 milestone Nov 15, 2018

pesse added a commit that referenced this issue Nov 15, 2018

Make sure cli outputs usage in case of an error
For example when no command is provided.
Fixes #110

@pesse pesse closed this in #113 Nov 15, 2018

felipebz added a commit to felipebz/utPLSQL-cli that referenced this issue Mar 18, 2019

Make sure cli outputs usage in case of an error
For example when no command is provided.
Fixes utPLSQL#110
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.