Skip to content

@viniciusam viniciusam released this Dec 22, 2018

Compatibility

This version of utPLSQL-maven-plugin is compatible with all versions of utPLSQL from 3.0.0 to 3.1.x. We encourage you to always use the latest version of the plugin to communicate with a v3 core.

Prerequisites

Java SE Runtime Environment 8
Maven Version 3.5+

The plugin relies on the Java API for database operations, which has the OJDBC as a maven dependency. To be able to download the Oracle dependencies, you need to configure your access to Oracle's Maven Repository:

http://docs.oracle.com/middleware/1213/core/MAVEN/config_maven_repo.htm#MAVEN9010

Sections 6.1 and 6.5 are the more important ones, and the only ones you need if you're using the latest Maven version.

Changes

  • Fix stack trace showing on tests failure.
Assets 2

@viniciusam viniciusam released this Oct 21, 2018 · 7 commits to develop since this release

Compatibility

This version of utPLSQL-maven-plugin is compatible with all versions of utPLSQL from 3.0.0 to 3.1.2. We encourage you to always use the latest version of the plugin to communicate with a v3 core.

Prerequisites

Java SE Runtime Environment 8
Maven Version 3.5+

The plugin relies on the Java API for database operations, which has the OJDBC as a maven dependency. To be able to download the Oracle dependencies, you need to configure your access to Oracle's Maven Repository:

http://docs.oracle.com/middleware/1213/core/MAVEN/config_maven_repo.htm#MAVEN9010

Sections 6.1 and 6.5 are the more important ones, and the only ones you need if you're using the latest Maven version.

Changes

This is the first release of utPLSQL-maven-plugin, usage example can be found at:
https://github.com/utPLSQL/utPLSQL-maven-plugin#usage

Assets 2
You can’t perform that action at this time.