New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

uninitialized constant VagrantPlugins::ProviderLibvirt::Action::NFS #105

Closed
mlazarov opened this Issue Dec 13, 2013 · 12 comments

Comments

Projects
None yet
7 participants
@mlazarov
Copy link

mlazarov commented Dec 13, 2013

When following Install guide (https://github.com/pradels/vagrant-libvirt/blob/master/README.md) i have faced this error:

# vagrant up --provider=libvirt
Bringing machine 'test_vm' up with 'libvirt' provider...
root@localhost's password:
An error occurred while executing multiple actions in parallel.
Any errors that occurred are shown below.

An unexpected error ocurred when executing the action on the
'test_vm' machine. Please report this as a bug:

uninitialized constant VagrantPlugins::ProviderLibvirt::Action::NFS

/root/.vagrant.d/gems/gems/vagrant-libvirt-0.0.13/lib/vagrant-libvirt/action.rb:28:in `block (2 levels) in action_up'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/builtin/call.rb:47:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/builtin/call.rb:47:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/warden.rb:34:in `call'
/root/.vagrant.d/gems/gems/vagrant-libvirt-0.0.13/lib/vagrant-libvirt/action/connect_libvirt.rb:88:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/warden.rb:34:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/builtin/config_validate.rb:25:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/warden.rb:34:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/builder.rb:116:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/runner.rb:69:in `block in run'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/util/busy.rb:19:in `busy'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/action/runner.rb:69:in `run'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/machine.rb:147:in `action'
/opt/vagrant/embedded/gems/gems/vagrant-1.4.0/lib/vagrant/batch_action.rb:63:in `block (2 levels) in run'

I'm using latest version of Centos 6.5 and latest Vagrant rpm package - Vagrant 1.4.0

@kalabiyau

This comment has been minimized.

Copy link
Contributor

kalabiyau commented Dec 13, 2013

@mlazarov @pronix i am not sure if there is any confirmation about compatibility with vagrant 1.4.

Can you please try it with 1.3.5 ?

@mlazarov

This comment has been minimized.

Copy link

mlazarov commented Dec 13, 2013

Yep, confirmed - it works great with 1.3.5! Thanks @kalabiyau!

@mlazarov mlazarov closed this Dec 13, 2013

@pronix pronix reopened this Dec 16, 2013

@teto

This comment has been minimized.

Copy link
Contributor

teto commented Jan 3, 2014

I am trying to help with this problem. My latest commit https://github.com/teto/vagrant-libvirt/tree/kernel hides the error but does not solve the problem I guess. I have another problem like "No host IP was given to the Vagrant core NFS helper". I am trying to get around that

@sciurus

This comment has been minimized.

Copy link
Collaborator

sciurus commented Jan 11, 2014

Hi teto, thanks for working on this. I'll try to help with vagrant 1.4 compatibility once I finish working on some other issues.

@lokI8

This comment has been minimized.

Copy link

lokI8 commented Jul 11, 2014

Hello, I'm working with vagrant 1.6.3 and have received the same error. Should I revert back to 1.3, or has compatibility of a more recent version been fixed? Thanks!

@sciurus

This comment has been minimized.

Copy link
Collaborator

sciurus commented Jul 11, 2014

In my testing vagrant-libvirt works with 1.6.3. What version of vagrant-libvirt do you have installed?

@teto

This comment has been minimized.

Copy link
Contributor

teto commented Jul 11, 2014

Post a full debug log, that could help (maybe). The problem (which was
trivial) should have been fixed.

2014-07-11 23:14 GMT+02:00 Brian Pitts notifications@github.com:

In my testing vagrant-libvirt works with 1.6.3. What version of
vagrant-libvirt do you have installed?


Reply to this email directly or view it on GitHub
#105 (comment)
.

@lokI8

This comment has been minimized.

Copy link

lokI8 commented Jul 11, 2014

I'm using version 0.0.8, it is apparently another bug that that is the default using "vagrant plugin install" at the moment. I presume i should be using version 0.0.16? How do I install it? "vagrant plugin update" does not update past 0.0.8.

@sciurus

This comment has been minimized.

Copy link
Collaborator

sciurus commented Jul 12, 2014

That's not a bug in vagrant-libvirt as far as I can tell. I was able to reproduce that problem now, so I'll report it to vagrant developers.

vagrant plugin install vagrant-libvirt --plugin-version=0.0.19 should get the latest release at the time of this comment.

@lelutin

This comment has been minimized.

Copy link

lelutin commented Sep 3, 2014

I'm using 1.6.4 and trying out your workaround and it seems as though they bumped up the requirements quite a log and vagrant-libvirt isn't able to follow. I get:

$ vagrant plugin install vagrant-libvirt --plugin-version=0.0.19
Installing the 'vagrant-libvirt --version '0.0.19'' plugin. This can take a few minutes...
The plugin(s) can't be installed due to the version conflicts below.
This means that the plugins depend on a library version that conflicts
with other plugins or Vagrant itself, creating an impossible situation
where Vagrant wouldn't be able to load the plugins.

You can fix the issue by either removing a conflicting plugin or
by contacting a plugin author to see if they can address the conflict.

Vagrant could not find compatible versions for gem "nokogiri":
  In Gemfile:
    vagrant-libvirt (= 0.0.19) ruby depends on
      nokogiri (~> 1.5.9) ruby

    vagrant (= 1.6.4) ruby depends on
      nokogiri (1.6.3.1)
@sciurus

This comment has been minimized.

Copy link
Collaborator

sciurus commented Sep 3, 2014

Thanks for reporting this. We've changed our gemspec to accept Nokogiri 1.6.x, so once @pronix makes a new release we should be installable again. AFAICT once #216 is merged we're in okay shape for a release.

@sciurus

This comment has been minimized.

Copy link
Collaborator

sciurus commented Sep 5, 2014

@lelutin 0.0.20 has been released and should fix your installation problem.

$ sudo dpkg -i Downloads/vagrant_1.6.5_x86_64.deb 
(Reading database ... 537227 files and directories currently installed.)
Preparing to replace vagrant 1:1.6.3 (using .../vagrant_1.6.5_x86_64.deb) ...
Unpacking replacement vagrant ...
Setting up vagrant (1:1.6.5) ...
pittsb@tullock:~$ vagrant plugin list
vagrant-login (1.0.1, system)
vagrant-share (1.1.1, system)
pittsb@tullock:~$ vagrant plugin install vagrant-libvirt
Installing the 'vagrant-libvirt' plugin. This can take a few minutes...
Installed the plugin 'vagrant-libvirt (0.0.20)'!

@pronix pronix closed this May 17, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment