Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

removed: xinerama build deps

git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@34839 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
  • Loading branch information...
commit c6f6688dbfb9992e791575731f0618598076aa66 1 parent e12b8dd
vdrfan authored
View
2  README.armel
@@ -218,7 +218,7 @@ It is also assumed that you have it setup with either Angstrom or Ubuntu.
For Angstrom:
# opkg update
- # opkg install subversion make g++ gcc gawk pmount libtool automake gperf unzip bison libsdl-1.2-dev libsdl-image-1.2-dev libsdl-gfx-dev libsdl-mixer-1.2-dev libfribidi-dev liblzo-dev libfreetype-dev libsqlite3-dev libasound2 python-sqlite3 libcurl4 xineramaproto-dev libxinerama-dev libxrandr-dev libxrender-dev libmad-dev libogg-dev libvorbis-dev libmysqlclient-dev libpcre-dev libdbus-glib-1-dev hal-dev libjasper-dev libfontconfig-dev boost-dev libfaac-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libsamplerate0-dev
+ # opkg install subversion make g++ gcc gawk pmount libtool automake gperf unzip bison libsdl-1.2-dev libsdl-image-1.2-dev libsdl-gfx-dev libsdl-mixer-1.2-dev libfribidi-dev liblzo-dev libfreetype-dev libsqlite3-dev libasound2 python-sqlite3 libcurl4 libxrandr-dev libxrender-dev libmad-dev libogg-dev libvorbis-dev libmysqlclient-dev libpcre-dev libdbus-glib-1-dev hal-dev libjasper-dev libfontconfig-dev boost-dev libfaac-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libsamplerate0-dev
Unfortunately this will only install the packages that are available through opkg. There will be further packages that need to be installed.
Either use the method mentioned below, or selectively find and install packages, mentioned at the bottom of this README.
View
2  README.linux
@@ -44,7 +44,7 @@ Build-Depends: debhelper (>= 7.0.50), quilt, python-support, cmake,
libfontconfig-dev, libbz2-dev, libfribidi-dev, libsqlite3-dev,
libmysqlclient-dev, libasound-dev, libpng-dev, libpcre3-dev, liblzo2-dev,
libcdio-dev, libsdl-dev, libsdl-image1.2-dev, libsdl-mixer1.2-dev, libenca-dev,
- libjasper-dev, libxt-dev, libxtst-dev, libxmu-dev, libxinerama-dev, libcurl3,
+ libjasper-dev, libxt-dev, libxtst-dev, libxmu-dev, libcurl3,
libcurl4-gnutls-dev | libcurl-dev, libdbus-1-dev, libhal-storage-dev,
libhal-dev, libpulse-dev, libavahi-common-dev, libavahi-client-dev,
libxrandr-dev, libavcodec-dev, libavformat-dev, libavutil-dev, libpostproc-dev,
View
2  README.ubuntu
@@ -44,7 +44,7 @@ Two methods exist to install the required Ubuntu packages:
For Ubuntu (all versions >= 7.04):
- # sudo aptitude install subversion make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-gnutls-dev x11proto-xinerama-dev libxinerama-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libfaac-dev libenca-dev libxt-dev libxtst-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmms-dev libmpeg3-dev libfaad-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libssh-dev gettext cvs
+ # sudo aptitude install subversion make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-gnutls-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libfaac-dev libenca-dev libxt-dev libxtst-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmms-dev libmpeg3-dev libfaad-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libssh-dev gettext cvs
On 8.10 and older versions, libcurl is outdated and thus XBMC will not compile properly.
In this case you will have to manually compile the latest version.
View
3  configure.in
@@ -651,9 +651,6 @@ else
PKG_CHECK_MODULES([XMU], [xmu],
[INCLUDES="$INCLUDES $XMU_CFLAGS"; LIBS="$LIBS $XMU_LIBS"],
AC_MSG_ERROR($missing_library))
- PKG_CHECK_MODULES([XINERAMA],[xinerama],
- [INCLUDES="$INCLUDES $XINERAMA_CFLAGS"; LIBS="$LIBS $XINERAMA_LIBS"],
- AC_MSG_ERROR($missing_library))
PKG_CHECK_MODULES([CURL], [libcurl],
[INCLUDES="$INCLUDES $CURL_CFLAGS"; LIBS="$LIBS $CURL_LIBS"],
AC_MSG_ERROR($missing_library))
View
2  tools/Linux/packaging/debian/control
@@ -12,7 +12,7 @@ Build-Depends: debhelper (>= 7.0.50~), python-support, cmake,
libsqlite3-dev, libmysqlclient-dev, libasound-dev, libpng12-dev | libpng-dev,
libpcre3-dev, liblzo2-dev, libcdio-dev, libsdl-dev, libsdl-image1.2-dev,
libsdl-mixer1.2-dev, libenca-dev, libjasper-dev, libxt-dev, libxtst-dev,
- libxmu-dev, libxinerama-dev, libcurl4-gnutls-dev | libcurl-dev,
+ libxmu-dev, libcurl4-gnutls-dev | libcurl-dev,
libdbus-1-dev, libhal-storage-dev, libhal-dev, libpulse-dev,
libavahi-common-dev, libavahi-client-dev, libxrandr-dev, libavcodec-dev,
libavformat-dev, libavutil-dev, libpostproc-dev, libswscale-dev,
View
2  tools/Linux/packaging/debian/var_info
@@ -10,7 +10,7 @@ BUILD_DEPENDS="debhelper (>= 7.0.50~), python-support, cmake,
libsqlite3-dev, libmysqlclient-dev, libasound-dev, libpng12-dev | libpng-dev,
libpcre3-dev, liblzo2-dev, libcdio-dev, libsdl-dev, libsdl-image1.2-dev,
libsdl-mixer1.2-dev, libenca-dev, libjasper-dev, libxt-dev, libxtst-dev,
- libxmu-dev, libxinerama-dev, libcurl4-gnutls-dev | libcurl-dev,
+ libxmu-dev, libcurl4-gnutls-dev | libcurl-dev,
libdbus-1-dev, libhal-storage-dev, libhal-dev, libpulse-dev,
libavahi-common-dev, libavahi-client-dev, libxrandr-dev, libavcodec-dev,
libavformat-dev, libavutil-dev, libpostproc-dev, libswscale-dev,
View
2  tools/arm/arm-scripts/pkg-paths.txt
@@ -37,8 +37,6 @@ http://ftp.uk.debian.org/debian/pool/main/e/enca/libenca0_1.9-6_armel.deb
http://ftp.uk.debian.org/debian/pool/main/j/jasper/libjasper-dev_1.900.1-5.1_armel.deb
http://ftp.uk.debian.org/debian/pool/main/libm/libmms/libmms-dev_0.4-2_armel.deb
http://ftp.uk.debian.org/debian/pool/main/libm/libmms/libmms0_0.4-2_armel.deb
-http://ftp.uk.debian.org/debian/pool/main/libx/libxinerama/libxinerama-dev_1.0.3-2_armel.deb
-http://ftp.uk.debian.org/debian/pool/main/x/x11proto-xinerama/x11proto-xinerama-dev_1.1.2-5_all.deb
http://ftp.uk.debian.org/debian/pool/main/c/curl/libcurl4-gnutls-dev_7.18.2-8lenny3_armel.deb
http://ftp.uk.debian.org/debian/pool/main/c/curl/libcurl3-gnutls_7.18.2-8lenny3_armel.deb
http://ftp.uk.debian.org/debian/pool/main/libi/libidn/libidn11_1.8+20080606-1_armel.deb
View
3  xbmc-xrandr.c
@@ -1075,8 +1075,7 @@ apply (void)
/*
* Hold the server grabbed while messing with
* the screen so that apps which notice the resize
- * event and ask for xinerama information from the server
- * receive up-to-date information
+ * event receive up-to-date information
*/
XGrabServer (dpy);
Please sign in to comment.
Something went wrong with that request. Please try again.