lifted-base can not be installed because of cabal library version #28

Closed
RudolfVonKrugstein opened this Issue Oct 31, 2012 · 6 comments

Projects

None yet

3 participants

@RudolfVonKrugstein
Contributor

When I try to install lifted-base (it is a dependency) with haste-inst, I get:

Resolving dependencies...
In order, the following will be installed:
lifted-base-0.2 (reinstall)
Warning: Note that reinstalls are always dangerous. Continuing anyway...
cabal: Error: some packages failed to install:
lifted-base-0.2 failed during the configure step. The exception was:
user error (The package requires Cabal library version -any && >=1.9.2 but no
suitable version is installed.)
@RudolfVonKrugstein
Contributor

I found a workaround:

cabal unpack lifted-base
cd lifted-base
cabal install
haste-inst install
@valderman
Owner

That workaround might be dangerous; it configures the package to build against the vanilla GHC packages, so you'll end up depending on them rather than the Haste ones. That may (sort of) work at the moment, but will definitely cause breakage in the future.

@RudolfVonKrugstein
Contributor

I have the same problem also with comonads

@valderman
Owner

This problem may be solved as of 0.2.7 - is it still there?

@tdeekens

I still have this issue getting:

19 warnings and 1 error generated.
Failed to install lifted-base-0.2.1.0
cabal: Error: some packages failed to install:
lifted-base-0.2.1.0 failed during the building phase. The exception was:
ExitFailure 1

using the latest cabal. The unpack-trick did not work either. Any ideas? This makes ghc-mod and hlint etc fail to install.

@valderman
Owner

Fixed on master by the new haste-cabal.

@valderman valderman closed this Aug 22, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment