Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

VerifyError on all tests #21

Closed
bartspedden opened this Issue Apr 27, 2012 · 4 comments

Comments

Projects
None yet
2 participants

Using gradle 1.0-rc-2 and cobertura plugin version 1.2 all of my tests fail with the following type of error:

java.lang.VerifyError: Expecting a stackmap frame at branch target 447 in method com.safetyweb.iae.messaging.AZMQConnector.connect()V at offset 78

If I run "gradle test" the tests work, so I believe that it has something specific to do with the cobertura plugin. Also, the same project has a pre-existing build using maven and cobertura works from maven.

Let me know what additional information you need to debug.

Thanks,

Bart

Collaborator

jvanderpol commented Apr 27, 2012

Nice catch jvanderpol, I was using java 7, but don't really need to. I switched to java 1.6.0_29 and now I'm seeing the following error while just trying to do a "gradle tasks":

Execution failed for task ':tasks'.

java.util.ConcurrentModificationException (no error message)

The error goes away when I comment out:

buildscript {
apply from: 'https://github.com/valkolovos/gradle_cobertura/raw/master/repo/gradle_cobertura/gradle_cobertura/1.2/coberturainit.gradle'
}

Collaborator

jvanderpol commented Apr 30, 2012

That is a known issue: #18 (comment)

Thank you, that worked.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment