New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

application runing failed..... #154

Closed
Matrix-Zhang opened this Issue Feb 3, 2016 · 5 comments

Comments

Projects
None yet
2 participants
@Matrix-Zhang

Matrix-Zhang commented Feb 3, 2016

after the comit 3b94bb8, the vsgi applistion can not starup....

(process:30797): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

** (process:30797): CRITICAL *: vsgi_server_set_application_callback: assertion 'self != NULL' failed
*
Message: fuck run here.

(process:30797): GLib-GIO-CRITICAL **: g_application_run: assertion 'G_IS_APPLICATION (application)' failed

i add some log in the C file...

i checkout that the function vsgi_scgi_server_new, return NULL ?

@arteymix

This comment has been minimized.

Show comment
Hide comment
@arteymix

arteymix Feb 3, 2016

Member

Is it related to #155 ?

I don't have sufficient information to tell you what's going wrong here. It just seems that the shared library for SCGI is not loaded.

In the meantime, you should use a release, which are more stable. I fixed an important issue with SCGI that practically doubled the throughput.

Member

arteymix commented Feb 3, 2016

Is it related to #155 ?

I don't have sufficient information to tell you what's going wrong here. It just seems that the shared library for SCGI is not loaded.

In the meantime, you should use a release, which are more stable. I fixed an important issue with SCGI that practically doubled the throughput.

@Matrix-Zhang

This comment has been minimized.

Show comment
Hide comment
@Matrix-Zhang

Matrix-Zhang Feb 4, 2016

no, it is a new issue in master branch...

i change to the latest release 0.28 is OK

Matrix-Zhang commented Feb 4, 2016

no, it is a new issue in master branch...

i change to the latest release 0.28 is OK

@arteymix

This comment has been minimized.

Show comment
Hide comment
@arteymix

arteymix Feb 4, 2016

Member

I got the same issue with the installed files on my side. I must have missed something when I extracted implementations into separated shared libraries.

I will backport fixes for FastCGI into another hotfix release. I got the async I/O working :)

I'll fix that, promise!

Member

arteymix commented Feb 4, 2016

I got the same issue with the installed files on my side. I must have missed something when I extracted implementations into separated shared libraries.

I will backport fixes for FastCGI into another hotfix release. I got the async I/O working :)

I'll fix that, promise!

@arteymix arteymix added the bug label Feb 4, 2016

@arteymix arteymix added this to the 0.3.0 milestone Feb 4, 2016

@arteymix

This comment has been minimized.

Show comment
Hide comment
@arteymix

arteymix Feb 4, 2016

Member

It's the [ModuleInit] directives that breaks everything. It registers GObject types only through plugin_init, which is not desirable.

I will figure out something when merging #130.

Member

arteymix commented Feb 4, 2016

It's the [ModuleInit] directives that breaks everything. It registers GObject types only through plugin_init, which is not desirable.

I will figure out something when merging #130.

@arteymix arteymix closed this in 5e10ef1 Feb 4, 2016

@arteymix

This comment has been minimized.

Show comment
Hide comment
@arteymix

arteymix Feb 4, 2016

Member

@Matrix-Zhang I backported the fixes for FastCGI to support async I/O in v0.2.9 (I think you wanted to use that at first)

SCGI is much more performant though.

Member

arteymix commented Feb 4, 2016

@Matrix-Zhang I backported the fixes for FastCGI to support async I/O in v0.2.9 (I think you wanted to use that at first)

SCGI is much more performant though.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment