Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add Go 1.18 support #1253

Merged
merged 8 commits into from Mar 20, 2022
Merged

Conversation

Aoang
Copy link
Contributor

@Aoang Aoang commented Mar 18, 2022

No description provided.

@Aoang
Copy link
Contributor Author

Aoang commented Mar 18, 2022

Results:


[/home/runner/work/fasthttp/fasthttp/server.go:1776] - G402 (CWE-295): TLS MinVersion too low. (Confidence: HIGH, Severity: HIGH)
    1775: 	if s.TLSConfig == nil {
  > 1776: 		s.TLSConfig = &tls.Config{}
    1777: 	}



[/home/runner/work/fasthttp/fasthttp/examples/letsencrypt/letsencryptserver.go:23-28] - G402 (CWE-295): TLS MinVersion too low. (Confidence: HIGH, Severity: HIGH)
    22: 
  > 23: 	cfg := &tls.Config{
  > 24: 		GetCertificate: m.GetCertificate,
  > 25: 		NextProtos: []string{
  > 26: 			"http/1.1", acme.ALPNProto,
  > 27: 		},
  > 28: 	}
    29: 



[/home/runner/work/fasthttp/fasthttp/client.go:1898] - G402 (CWE-295): TLS MinVersion too low. (Confidence: HIGH, Severity: HIGH)
    1897: 	if c == nil {
  > 1898: 		c = &tls.Config{}
    1899: 	} else {

This pull request should not handle this https://github.com/valyala/fasthttp/runs/5595807170?check_suite_focus=true

@Aoang
Copy link
Contributor Author

Aoang commented Mar 18, 2022

TBR

@erikdubbelboer erikdubbelboer merged commit f3bce3a into valyala:master Mar 20, 2022
14 checks passed
@erikdubbelboer
Copy link
Collaborator

erikdubbelboer commented Mar 20, 2022

Thanks!

u5surf pushed a commit to u5surf/fasthttp that referenced this issue Mar 23, 2022
* Add Go 1.18 support

* fix Gosec Security Scanner

https://github.com/valyala/fasthttp/runs/5595618634?check_suite_focus=true

* fix securego/gosec#469 (comment) Gosec Github Action Doesn't Work at Go 1.18

* fix golangci/golangci-lint#2438 golangci/golangci-lint Doesn't Work at Go 1.18

* fix golint unused

* fix golint: SA1019: netErr.Temporary is deprecated

* fix valyala#1256
u5surf pushed a commit to u5surf/fasthttp that referenced this issue Mar 23, 2022
* Add Go 1.18 support

* fix Gosec Security Scanner

https://github.com/valyala/fasthttp/runs/5595618634?check_suite_focus=true

* fix securego/gosec#469 (comment) Gosec Github Action Doesn't Work at Go 1.18

* fix golangci/golangci-lint#2438 golangci/golangci-lint Doesn't Work at Go 1.18

* fix golint unused

* fix golint: SA1019: netErr.Temporary is deprecated

* fix valyala#1256
@Aoang Aoang deleted the add-go-1-18-support branch Aug 14, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants