Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Plugincontroller->GetUserMeta default broken in current master #2057

Closed
bleistivt opened this Issue Aug 30, 2014 · 2 comments

Comments

Projects
None yet
3 participants
@bleistivt
Copy link
Contributor

commented Aug 30, 2014

$this->GetUserMeta($UserID, 'Test', true);

called from a plugin should return ['Plugin.PluginName.Test' => true]
...but returns an empty array.

Still working in @9736ce1e01c0691f67e9fe8571556885f38d7deb
Broken in @2429347d96fa8c694d872b65459ed5af23cf8200

@bleistivt

This comment has been minimized.

Copy link
Contributor Author

commented Aug 31, 2014

I was able to hunt this down.

This commit is causing it:
@6287285

There is probably a bug in the none-cache logic in UserMetaModel->GetUserMeta
but the error didn't appear before, because it was using the fallback for a cache miss since it had the null cache "enabled".

@tburry

This comment has been minimized.

Copy link
Member

commented Sep 2, 2014

Thanks for the great catch. We'll be wanting to fix the user meta stuff which I'll get on.

@linc linc added this to the 2.3 milestone Sep 19, 2014

@linc linc added the Bug label Feb 14, 2015

@linc linc closed this in #2513 Feb 21, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.