Installation

vapir edited this page Sep 27, 2011 · 6 revisions

Installation

Prerequisites

  • Ruby
  • Knowledge of Ruby
    • Vapir is a library for the Ruby language. It is not its own language. You must know how to program in Ruby. There are many excellent tutorials on the Ruby language to be found scattered about these internets.
  • A browser
  • RubyGems

Install the flavor(s) of Vapir you want

If you want to drive IE:
gem install vapir-ie

If you want to drive Firefox:
gem install vapir-firefox

If you want to drive both:
gem install vapir-firefox vapir-ie

As usual, use sudo if you’re on something unix-like and need to install as root.