Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

How to upgrade VirtualBox #53

Open
Yamakasi opened this issue Aug 7, 2017 · 23 comments

Comments

Projects
None yet
7 participants
@Yamakasi
Copy link

commented Aug 7, 2017

Is there some howto how to upgrade the virtualbox version I have installed using the PortableVbox package ?

@p060477

This comment has been minimized.

Copy link

commented Aug 7, 2017

do you know that you won't be able to use bridged network,but only nat,
and no bi-directional drag and drop..??
..theese two BUGS are still there since so many years..
ask for them to Runar...Buvick...the "portable ghost"....
what a shame...

@Yamakasi

This comment has been minimized.

Copy link
Author

commented Aug 7, 2017

Can you please stop hijacking everyones topics ? thanks!

@Megachip

This comment has been minimized.

Copy link
Collaborator

commented Aug 10, 2017

@Yamakasi this should be happens automatically (if github/vbox.me stay up2date). It checks vboxinstall.ini line 4 for new updates. If there is a newer version. If there is a newer one, it will download and install it. But looks like this URL is not touched since 21-Mar-2012.

You could setup your own update mirror:
just put the vboxinstall.ini into the folder and rename it to vboxinstall.dat and create a 'update.dat' with the following content:

[version]
key=5122
[starter]
key=6410

Cause I have no time/possibilities to check the update process (atm) I will not update these values. But feel free to share you experience here. Especially if the upgrade from 4.1.10 (latest version on vbox.me) to 5.1.22 works without issues (if yes, possible someone could update the values there).

Repository owner deleted a comment from p060477 Aug 10, 2017

Repository owner deleted a comment from p060477 Aug 10, 2017

Repository owner deleted a comment from p060477 Aug 10, 2017

@p060477

This comment has been minimized.

Copy link

commented Aug 10, 2017

"P.S. a lot of ATMs working with windows NT (4.0 or below), so why not using win 7 ^^ ;) "...
..correct..for the joy of thieves..
is so strange that PVB is STOPPED to win 7
a SO older of YEARS
so many FREE, so NON PAID, sw are FULLY suitable with
newest vers of WIN 10
:)

@p060477

This comment has been minimized.

Copy link

commented Aug 10, 2017

ps : the problem is NOT only mine..but for the MILLIONS of people already using WIN 8 or WIN 10
:)

@gusbemacbe

This comment has been minimized.

Copy link

commented Aug 10, 2017

@Megachip, does it require admin privileges or rights to update?

@Megachip

This comment has been minimized.

Copy link
Collaborator

commented Aug 10, 2017

@gusbemacbe You need the same rights like to launch PVB, so at least admin priv. The update itself didn't need any Privilegs cause it just replaces the local files. But for launching drivers need to be registered and unregistered.

@gusbemacbe

This comment has been minimized.

Copy link

commented Aug 10, 2017

@Megachip Too bad, I do not use Windows on my Mac, I use VirtualBox to run a virtual machine from my external HD on a college lab computer.

@runarbu

This comment has been minimized.

Copy link
Collaborator

commented Aug 17, 2017

I have made a new binary for the newest version (5.1.26). It is 01:00 in the night her now, so I won't have time to test this much today, but if you want you can download it here: http://files.vbox.me/files/Portable-VirtualBox_v5.1.26-Starter_v6.4.10-Win_all.exe

If everything is fine I will publish it on the web page tomorrow.

@gusbemacbe

This comment has been minimized.

Copy link

commented Aug 17, 2017

Do not publish it now, bitte! Because I tested, it freezed the lab computer, it didn't open, and I couldn't type, I couldn't close the windows. I had to reboot. You need to fix the bugs firstly.

The most of lab computers use Windows 7 64bits.

@p060477

This comment has been minimized.

Copy link

commented Aug 18, 2017

@runarbu:
does it finally support network bridged?
does it finally support bi-drag n drop?
FOR WIN 10 64 bits obviously
if NOT please WRITE IT CLEARLY on yr vbox.me web page
instead of cheat win 10 billions of customers
CHEERS

@gusbemacbe

This comment has been minimized.

Copy link

commented Aug 18, 2017

Cheat? VBOX is OPEN SOURCE. Will you accuse Atom, Linux and other open source apps of cheating?

Sei il più stupido dall'Italia per non sapere che cosa è cheat ed open source. Sei un troll. I programmatori non sono i tuoi impiegati e schiavi, ragazzo frivolo. Tu non sei capo del Github.

@Megachip

This comment has been minimized.

Copy link
Collaborator

commented Aug 18, 2017

@gusbemacbe Hmm, I've tried the old installer with 5.1.26 and everything worked fine (except the known things). But this was a up2date win10. Have no Win 7 to test :(

Repository owner deleted a comment from p060477 Aug 18, 2017

@gusbemacbe

This comment has been minimized.

Copy link

commented Aug 18, 2017

@Megachip have you already tried to test on your friends' PCs with Windows 7?

Repository owner deleted a comment from p060477 Aug 18, 2017

@Megachip

This comment has been minimized.

Copy link
Collaborator

commented Aug 18, 2017

@gusbemacbe Sadly I know noone with Windows 7,8,8.1 :( and have not virtual boxes with this systems anymore (and no time to create them atm). So I think @runarbu should (as you said) wait, until someone confirms that it didn't install on Win7 or someone has the time and the Ressources to test all the different operating versions

@rdavydov

This comment has been minimized.

Copy link

commented Aug 21, 2017

@Megachip Could you specify what are the non-working known things? BTW guys, you have a mess in links and versions on vbox.me: in the Installation instructions it says version 5.1.22 but links to 5.0.26 and in the right sidebar it says Newest -> VirtualBox v5.0.26 but links, this time correctly, to 5.1.22.

@p060477

This comment has been minimized.

Copy link

commented Aug 21, 2017

@rdavydov: i reply immediately to yr clear questions:
1)if you have win 8, 8.1 or 10 you won't be able to use:
network bridged but only NAT
and you will not have bi directional drag and drop
2) the vbox.me page is a nightmare..they at least MUST write clearly what i've just write here above at
point 1)
it should be helpful not to have billions of people -misleaded-
3)i'm writing here theese simple things since 2015..but NO useful answers till now..

goodluck!!

@jlfarinha

This comment has been minimized.

Copy link

commented Sep 8, 2017

@Yamakasi - I know this is a workaround to the "official" way that the application can check for and install upgrades, but worked well for me - I managed to upgrade to the latest version of VirtualBox without loosing any settings nor VirtualMachines.

And I also managed to install the respective "Extension Pack" for that same version I upgraded to.

Still: to be on the safe side, before you start, make a copy of the folder where you have Portable-VirtualBox.exe, including all its contents and subfolders - if anything goes wrong you can copy everything back.

Successful under Windows 7 x64 - didn't try under any other OS version

Here's how it worked for me:

  1. Download the latest VirtualBox version from http://virtualbox.org and save it to the folder where you have Portable-VirtualBox.exe

  2. Download the respective "Virtual Box Extension Pack" from the same page, and also save it to folder where you have Portable-VirtualBox.exe

  3. Quit VirtualBox - even the icon from the System Tray - or close all running VMs and quit the Windows processes Portable-VirtualBox.exe and VirtualBox.exe - if necessary log off and back on, to make sure all running programs are closed

  4. Go to the folder where you have Portable-VirtualBox.exe and rename the folder app64 (*) to app64.old

  5. Start Portable-VirtualBox.exe - it will come up with the installation screen asking if you'd like to download VirtualBox or to chose where the download is located; chose the file downloaded in "Step 1)", above

  6. Go through the regular setup. If all goes well, at the end the new version will launch and you'll have all your VMs and settings intact.

(*) I'm using a 64 bit OS, so the folder in step 4), above, is named "app64" - I suspect that in a x86 / 32 bit OS, the folder will be named either app or app (x86) or similar.

Did it work?


Almost forgot, here is how I managed to install the Extension Pack downloaded in "Step 2)", above:

a. Quit VirtualBox - even the icon from the System Tray - or close all running VMs and quit the Windows processes Portable-VirtualBox.exe and VirtualBox.exe - if necessary log off and back on, to make sure all running programs are closed

b. Go to the folder where your downloaded the Oracle_VM_VirtualBox_Extension_Pack-xxxx.VBOX-EXTPACK - make sure it's for the exact VirtualBox version that you have - then double-click it

c. Choose "Select a program from a list of installed programs" and click "OK"

d. Click "Browse", then navigate to to the folder where you have _Portable-VirtualBox.exe_and navigate to .\app64 then select VirtualBox.exe and click "Open"

e. VirtualBox will open and start installing the "Extension Pack" - you'll not see any of the VMs, but no worries, they'll be back - just follow the installation steps.

(If it fails with a warning of not having permissions, make sure you really went through "Step a)", above

f. Follow again "Step a)", above, then launch_Portable-VirtualBox.exe_ - your VMs should all be visible, and you should have the "Extension Pack" installed.

You can test that it installed successfully by going to the settings of a VM and enabling "USB 3.0" - as you know, without the "Extension Pack" you're limited to "USB 1.0".

Hope this helps!


Update Oct 23, 2018 - the user logged in needs to be part of the "Local Administrators" group, so that he / she can install the extension pack in the way described above.

Still working for version 5.2.20

@jlfarinha

This comment has been minimized.

Copy link

commented Sep 8, 2017

@p060477 : are you using Google translate and is it failing on you?

@gusbemacbe

This comment has been minimized.

Copy link

commented Sep 8, 2017

@jlfarinha, do not waste time with him. It is an Italian troll. He hijacked every topic and blamed the developers and called them cheaters and thieves.

@p060477

This comment has been minimized.

Copy link

commented Sep 9, 2017

@jlfarinha : DID yr workaround solved the 2 BIG BUGS still there due to the lack of its developer:
1) are you able to use BRIDGED NETW or ONLY NAT ?
2) have you a bi-dir Drag n Drop ?

if not you all are only a MESS!!!
or carrying on old so as win 7
cheers!!
;)
:)

@gusbemacbe

This comment has been minimized.

Copy link

commented Sep 9, 2017

@p060477, fuck you and go to hell. You should be banned from GitHub!

@p060477

This comment has been minimized.

Copy link

commented Sep 9, 2017

@LORDgusbemacbe:
1)are you able to use network bridged and bi dir drag n drop with s.o newer then the oldest win 7?
if yes i'm a troll...it NO you really are a MESS
2)you should be banned due to yr language..
3) are you try to admit at trinity college in cambridge..??

cheers!
:)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.