New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No 'error' provided in response body happening almost every time for one user #104

Closed
vdesabou opened this Issue Nov 9, 2015 · 14 comments

Comments

2 participants
@vdesabou
Owner

vdesabou commented Nov 9, 2015

Example:

screen shot on 2015-11-05 at 19_50_31

@vdesabou vdesabou added the bug label Nov 9, 2015

@vdesabou vdesabou self-assigned this Nov 9, 2015

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman Nov 9, 2015

Some background:
I am in the US, but I live in Hawaii (specifically Kauai) so maybe that has something to do with it?
Also about a month ago I was having trouble reaching Spotify's website via browser. I could reach the player just fine, but not the normal website, or their support pages. I would either get a cannot connect to server message (this: http://d.pr/n/1iXIw) or I would get a different language version of the site, something like Malaysian.
(not sure if that helps.)

roccitman commented Nov 9, 2015

Some background:
I am in the US, but I live in Hawaii (specifically Kauai) so maybe that has something to do with it?
Also about a month ago I was having trouble reaching Spotify's website via browser. I could reach the player just fine, but not the normal website, or their support pages. I would either get a cannot connect to server message (this: http://d.pr/n/1iXIw) or I would get a different language version of the site, something like Malaysian.
(not sure if that helps.)

@vdesabou

This comment has been minimized.

Show comment
Hide comment
@vdesabou

vdesabou Nov 10, 2015

Owner

Can you install this Beta version https://infinit.io/_/cZadweR and let me know if this is better?
It includes a fix made for this problem jwilsson/spotify-web-api-php#32

Owner

vdesabou commented Nov 10, 2015

Can you install this Beta version https://infinit.io/_/cZadweR and let me know if this is better?
It includes a fix made for this problem jwilsson/spotify-web-api-php#32

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman Nov 10, 2015

Yea! Seems to work great: http://d.pr/v/18ZnV http://d.pr/v/18ZnV

On Nov 10, 2015, at 5:40 AM, Vincent notifications@github.com wrote:

Can you install this Beta version https://infinit.io/_/cZadweR https://infinit.io/_/cZadweR and let me know if this is better?
It includes a fix made for this problem jwilsson/spotify-web-api-php#32 jwilsson/spotify-web-api-php#32

Reply to this email directly or view it on GitHub #104 (comment).

roccitman commented Nov 10, 2015

Yea! Seems to work great: http://d.pr/v/18ZnV http://d.pr/v/18ZnV

On Nov 10, 2015, at 5:40 AM, Vincent notifications@github.com wrote:

Can you install this Beta version https://infinit.io/_/cZadweR https://infinit.io/_/cZadweR and let me know if this is better?
It includes a fix made for this problem jwilsson/spotify-web-api-php#32 jwilsson/spotify-web-api-php#32

Reply to this email directly or view it on GitHub #104 (comment).

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman Nov 11, 2015

Some more odd errors. Might be a different thing. This is low priority, it's still working, just complaining about something
Debug tar: http://d.pr/f/sMNz
Screenshot: http://d.pr/i/LO88
Screenshot: http://d.pr/i/1dIaH

roccitman commented Nov 11, 2015

Some more odd errors. Might be a different thing. This is low priority, it's still working, just complaining about something
Debug tar: http://d.pr/f/sMNz
Screenshot: http://d.pr/i/LO88
Screenshot: http://d.pr/i/1dIaH

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman commented Nov 11, 2015

Another API error: http://d.pr/i/13qQV

vdesabou added a commit that referenced this issue Nov 12, 2015

vdesabou added a commit that referenced this issue Nov 12, 2015

@vdesabou vdesabou added this to the 6.2.4 milestone Nov 12, 2015

@vdesabou

This comment has been minimized.

Show comment
Hide comment
@vdesabou

vdesabou Nov 12, 2015

Owner

Another API error: http://d.pr/i/13qQV

It looks like an temp error, is it reproducible on your side?

Owner

vdesabou commented Nov 12, 2015

Another API error: http://d.pr/i/13qQV

It looks like an temp error, is it reproducible on your side?

@vdesabou

This comment has been minimized.

Show comment
Hide comment
@vdesabou

vdesabou Nov 12, 2015

Owner

I fixed the two mentioned exceptions, here is a beta link: https://infinit.io/_/mRMCGBZ

Owner

vdesabou commented Nov 12, 2015

I fixed the two mentioned exceptions, here is a beta link: https://infinit.io/_/mRMCGBZ

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman Nov 12, 2015

Loading beta now. The API problem seems to go back and forth. Works now: http://d.pr/i/1lnH2

roccitman commented Nov 12, 2015

Loading beta now. The API problem seems to go back and forth. Works now: http://d.pr/i/1lnH2

@vdesabou

This comment has been minimized.

Show comment
Hide comment
@vdesabou

vdesabou Nov 12, 2015

Owner

ok thanks for the feedback!
Would you mind help me test this beta https://infinit.io/_/35S4HVp

I've tried to simplify the spot_mini_debug process by automatically generating an email with information and a link to uploaded TGZ file (where sensible data has been removed).

So if you can install the Beta and then call spot_mini_debugand then select Send an email .., and then send me the generated email

Owner

vdesabou commented Nov 12, 2015

ok thanks for the feedback!
Would you mind help me test this beta https://infinit.io/_/35S4HVp

I've tried to simplify the spot_mini_debug process by automatically generating an email with information and a link to uploaded TGZ file (where sensible data has been removed).

So if you can install the Beta and then call spot_mini_debugand then select Send an email .., and then send me the generated email

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman Nov 12, 2015

Email sent. Nice addition.

No sooner than I told you the API was working I started getting this again: http://d.pr/i/Enze. I guess their API service is spotty (no pun intended).

roccitman commented Nov 12, 2015

Email sent. Nice addition.

No sooner than I told you the API was working I started getting this again: http://d.pr/i/Enze. I guess their API service is spotty (no pun intended).

@vdesabou

This comment has been minimized.

Show comment
Hide comment
@vdesabou

vdesabou Nov 12, 2015

Owner

Thanks for trying the spot_mini_debug command, it worked well!

Can you try to launch multiple times this command in a terminal window and
paste the output:

curl -v https://api.spotify.com

I’ve tried a workaround described here
http://stackoverflow.com/questions/28366402/failed-to-connect-to-www-googleapis-com-port-443-network-unreachable

Can you install this beta version and let me know if you still get this
intermittent issue? https://infinit.io/_/9CTbC4w

On Thu, Nov 12, 2015 at 5:11 PM, roccitman notifications@github.com wrote:

Email sent. Nice addition.

No sooner than I told you the API was working I started getting this
again: http://d.pr/i/Enze. I guess their API service is spotty (no pun
intended).


Reply to this email directly or view it on GitHub
#104 (comment)
.

Vincent de Saboulin

Owner

vdesabou commented Nov 12, 2015

Thanks for trying the spot_mini_debug command, it worked well!

Can you try to launch multiple times this command in a terminal window and
paste the output:

curl -v https://api.spotify.com

I’ve tried a workaround described here
http://stackoverflow.com/questions/28366402/failed-to-connect-to-www-googleapis-com-port-443-network-unreachable

Can you install this beta version and let me know if you still get this
intermittent issue? https://infinit.io/_/9CTbC4w

On Thu, Nov 12, 2015 at 5:11 PM, roccitman notifications@github.com wrote:

Email sent. Nice addition.

No sooner than I told you the API was working I started getting this
again: http://d.pr/i/Enze. I guess their API service is spotty (no pun
intended).


Reply to this email directly or view it on GitHub
#104 (comment)
.

Vincent de Saboulin

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman Nov 12, 2015

I'll do this when I get home, but I think therein might lie the problem. I think these issues might be caused by my modem/router. I cannot replicate any of the errors while on a different wi-fi connection.
More soon.

roccitman commented Nov 12, 2015

I'll do this when I get home, but I think therein might lie the problem. I think these issues might be caused by my modem/router. I cannot replicate any of the errors while on a different wi-fi connection.
More soon.

@roccitman

This comment has been minimized.

Show comment
Hide comment
@roccitman

roccitman commented Nov 13, 2015

@vdesabou

This comment has been minimized.

Show comment
Hide comment
@vdesabou

vdesabou Nov 13, 2015

Owner

ok thanks. Let's follow up on new issue #106 because this particular issue is fixed now and version 6.2.4 is out.
Thanks

Owner

vdesabou commented Nov 13, 2015

ok thanks. Let's follow up on new issue #106 because this particular issue is fixed now and version 6.2.4 is out.
Thanks

@vdesabou vdesabou closed this Nov 13, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment