Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

chore: add memory-fs to the devDependencies #927

Merged
merged 1 commit into from May 25, 2022

Conversation

shogo82148
Copy link
Contributor

@shogo82148 shogo82148 commented May 25, 2022

It looks that ncc depends to memory-fs directly, but it is not in the dependencies.

const MemoryFS = require("memory-fs");

This pull request will fix a broken build in #921

@shogo82148 shogo82148 requested review from styfle and Timer as code owners May 25, 2022
@styfle styfle changed the title add memory-fs to the devDependencies chore: add memory-fs to the devDependencies May 25, 2022
@@ -71,6 +71,7 @@
"mailgun": "^0.5.0",
"mariadb": "^2.0.1-beta",
"memcached": "^2.2.2",
"memory-fs": "^0.5.0",
Copy link
Member

@styfle styfle May 25, 2022

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

You'll need to run yarn install so that it updates the yarn.lock file too

Copy link
Contributor Author

@shogo82148 shogo82148 May 25, 2022

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I did.
However yarn.lock is not updated, because memory-fs already exists in yarn.lock.

ncc/yarn.lock

Lines 10208 to 10214 in c9238cc

memory-fs@^0.5.0:
version "0.5.0"
resolved "https://registry.yarnpkg.com/memory-fs/-/memory-fs-0.5.0.tgz#324c01288b88652966d161db77838720845a8e3c"
integrity sha512-jA0rdU5KoQMC0e6ppoNRtpp6vjFq6+NY7r8hywnC7V+1Xj/MtHwGIbB1QaK/dunyjWteJzmkpd7ooeWg10T7GA==
dependencies:
errno "^0.1.3"
readable-stream "^2.0.1"

$ yarn why memory-fs
yarn why v1.22.18
[1/4] 🤔  Why do we have the module "memory-fs"...?
[2/4] 🚚  Initialising dependency graph...
warning Resolution field "grpc@1.24.11" is incompatible with requested version "grpc@1.23.3"
[3/4] 🔍  Finding dependency...
[4/4] 🚡  Calculating file sizes...
=> Found "memory-fs@0.5.0"
info Has been hoisted to "memory-fs"
info Reasons this module exists
   - Specified in "devDependencies"
   - Hoisted from "ts-loader#enhanced-resolve#memory-fs"
info Disk size without dependencies: "52KB"
info Disk size with unique dependencies: "352KB"
info Disk size with transitive dependencies: "584KB"
info Number of shared dependencies: 9
✨  Done in 1.78s.

styfle
styfle approved these changes May 25, 2022
Copy link
Member

@styfle styfle left a comment

Thanks!

@styfle styfle merged commit 26b6460 into vercel:main May 25, 2022
7 checks passed
@shogo82148 shogo82148 deleted the add-memory-fs-to-dependency branch May 25, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants