New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Version 2.4.1 Not Connecting #13

Open
WIGGY17 opened this Issue Dec 21, 2017 · 25 comments

Comments

Projects
None yet
9 participants
@WIGGY17
Copy link

WIGGY17 commented Dec 21, 2017

I have a CoinBase account , I have bought XVG on Coinbase via BTC and sent it across to my Electrum XVG Wallet.
I've logged into my Wallet and all it says is "NOT CONNECTED" in the bottom left hand corner and there is a big Red button on the bottom right hand corner obviously as a status to say its not on .

Can anyone help with this or is it a problem that we are all having ???

@waterboy94

This comment has been minimized.

Copy link

waterboy94 commented Dec 23, 2017

I have the same issue and i also transferred my money but nothing shows because its not connected. i looked up other threads and they mentioned that I can add new servers that work but theres no option to add servers and I cannot pen preferences!

@thangchung

This comment has been minimized.

Copy link

thangchung commented Dec 24, 2017

I have had the same issue. I had done the money transfer to the local wallet but just noticed that there was not connected to the server. Any ideas to make it work? Could any developer in this project tell me that?
@waterboy94 Which servers UIRs that you mentioned? I think we can add it to electrum-xvg.conf

@waterboy94

This comment has been minimized.

Copy link

waterboy94 commented Dec 24, 2017

This was posted on reddit recently: 83.169.38.218 port 50002 and this as well
"Just tested, electrum-xvg.party port 50002 is working for me right now as is the one i stated before. I am using windows 10 and the electrum wallet."

The entire thread is here:
https://www.reddit.com/r/vergecurrency/comments/7jxw0p/xvg_wallet_not_connecting/

If you can make use of the info in the thread and make it work please provide me with instructions sicne Im a newbie lol

@thangchung

This comment has been minimized.

Copy link

thangchung commented Dec 24, 2017

I think I found out the problem after struggled a lot of time with it.
They updated the server URLs at https://github.com/vergecurrency/electrum-xvg-tor/blob/master/lib/network.py#L23

Now step by step to make it working as following

  • Run Tor browser (because I used Tor)
  • In the network setting, put t4c6rftkx673mlqv.onion into the server, the port is 50001
  • Don't check Use SSL
  • Proxy SOCK5 because of Tor browser, localhost, and 9150 for the port.
  • Don't know if it is correct or not, but you need to move your mouse to the server textbox again and press Enter key.
    It's working for me.

vergeerror

Hope this help.

@WIGGY17

This comment has been minimized.

Copy link

WIGGY17 commented Dec 24, 2017

@waterboy94

This comment has been minimized.

Copy link

waterboy94 commented Dec 24, 2017

Thanks for the detailed explaination @thangchung. The issue I'm facing is that when I paste the server name you suggested it does not get added to the list of servers, instead the box closes and thats it. when I reopen it nothing is changed, the list of servers is not updated even though the new server is still in the server text box. I uploaded a screenshot to help show you what I mean.
Thanks in advance!
capture

@WIGGY17

This comment has been minimized.

Copy link

WIGGY17 commented Dec 24, 2017

Mines just like @waterboy94 and same issue, @thangchung have you got settings different via your control panel . Im on windows 10 👎

@WIGGY17

This comment has been minimized.

Copy link

WIGGY17 commented Dec 24, 2017

Also @waterboy94 it should be SOCKS5 in the Proxy:

@waterboy94

This comment has been minimized.

Copy link

waterboy94 commented Dec 25, 2017

Thanks for letting me know but sadly its still not working /: I tried on a different PC and same issue. Is it Windows 10 related?

@WIGGY17

This comment has been minimized.

Copy link

WIGGY17 commented Dec 25, 2017

@curt177

This comment has been minimized.

Copy link

curt177 commented Dec 25, 2017

windows 10 not connecting I tried all network settings above and removed firewall

@thangchung

This comment has been minimized.

Copy link

thangchung commented Dec 26, 2017

@WIGGY17 @waterboy94 To adding this address to the list below, just paste it in the textbox and then press ENTER key on your keyboard, it should store in the storage for a next time usage.

This is my config in <your path>\<your username>\AppData\Roaming\Electrum-XVG-tor\config

{
    "auto_connect": false, 
    "console-history": [
        "info", 
        "ping"
    ], 
    "dark_icon": false, 
    "gui_last_wallet": "<path>/Electrum-XVG-tor/wallets/default_wallet", 
    "gui_show_history": false, 
    "gui_show_receiving": false, 
    "is_maximized": true, 
    "lite_mode": false, 
    "proxy": "socks5:localhost:9150", 
    "server": "t4c6rftkx673mlqv.onion:50001:t", 
    "winpos-qt": [
        100, 
        100, 
        840, 
        456
    ]
}

If you want the address automatically showing in the list, just simply open the recent_servers file in current folder and add it. My list is following

[
    "t4c6rftkx673mlqv.onion:50001:t", 
    "gozwhpes24mi2bk7.onion:50002:s", 
    "qz6pnufyqjexudq6.onion:50001:t"
]

The price of XVG is down dramatically. Sadly Christmas and New Year for all of us :(

@Scottocaster

This comment has been minimized.

Copy link

Scottocaster commented Dec 27, 2017

Thangchung got it right! I was tearing the place apart this wallet is so badly designed! Once I used the method Thangchung posted it connected right up to the network! Now I just have to get the data from the last week that I couldn't connect but at least it's coming in now! Thanks!

@SICKFREDO

This comment has been minimized.

Copy link

SICKFREDO commented Dec 27, 2017

Just tried the above settings and I am still unable to connect.

@Scottocaster

This comment has been minimized.

Copy link

Scottocaster commented Dec 27, 2017

Did you do EXACTLY as he stated AND you opened a TOR browser window beforehand? The socks5 setting and everything he has stated has to be exact. I messed it up the first time I tried too.

@SICKFREDO

This comment has been minimized.

Copy link

SICKFREDO commented Dec 27, 2017

@Scottocaster Indeed i took screenshots of each step see below;

tor

wallet creation

wallet creation goes offline

wallet creation

network

connection attempt

failed

@SICKFREDO

This comment has been minimized.

Copy link

SICKFREDO commented Dec 27, 2017

I also just tried his config settings with the same results

@WIGGY17

This comment has been minimized.

Copy link

WIGGY17 commented Dec 27, 2017

Hi All

Is everyone's Wallet online on Chrome or do they have their Wallet like me via a zip folder in the Desktop :(
@thangchung Im glad its down at the min as at this rate i'm not getting this XVG back .

@endrec

This comment has been minimized.

Copy link

endrec commented Jan 1, 2018

I had the same issue, and figured out the cause.
By default tor runs the SOCKS5 proxy on port 9050, and the wallet tries to connect to port 9150.
So you have to change the port in the proxy settings.

image

@nguyenquocdat30

This comment has been minimized.

Copy link

nguyenquocdat30 commented Jan 5, 2018

Hello everybody . sorry because english my bad .
don't check Use SSL .
proxy SOCKS5 : localhost 9150
you can use default server ,
DEFAULT_SERVERS = {
'electrum-verge.xyz':{'t':'50001', 's':'50002'},
'electrum-xvg.stream':{'t':'50001', 's':'50002'},
'electrum-xvg.party':{'t':'50001', 's':'50002'},
'e1.verge-electrum.com':{'t':'50001', 's':'50002'},
'e2.verge-electrum.com':{'t':'50001', 's':'50002'},
'e3.verge-electrum.com':{'t':'50001', 's':'50002'}
}
update here :
https://github.com/vergecurrency/electrum-xvg/blob/master/lib/network.py

@waterboy94

This comment has been minimized.

Copy link

waterboy94 commented Jan 5, 2018

So I figured it out @WIGGY17. First of all download an internet browser called Tor. Once you download it, launch the program and keep the browser open. Then go to the config folder and do the solution @thangchung put up where you have to open the config folder suing notepad.
The config folder is found here according to @thangchung
<your username>\AppData\Roaming\Electrum-XVG-tor\config

After you open config using notepad, copy paste everything into a new text document and keep it as a back up then paste all the stuff @thangchung wrote in his solution:

{
"auto_connect": false,
"console-history": [
"info",
"ping"
],
"dark_icon": false,
"gui_last_wallet": "/Electrum-XVG-tor/wallets/default_wallet",
"gui_show_history": false,
"gui_show_receiving": false,
"is_maximized": true,
"lite_mode": false,
"proxy": "socks5:localhost:9150",
"server": "t4c6rftkx673mlqv.onion:50001:t",
"winpos-qt": [
100,
100,
840,
456
]
}

Then I left the wallet for a bit and when I was back, BOOM, it was connected :D

Kudos to @thangchung

@WIGGY17

This comment has been minimized.

Copy link

WIGGY17 commented Jan 5, 2018

@nguyenquocdat30

This comment has been minimized.

Copy link

nguyenquocdat30 commented Apr 5, 2018

You can watch this Video : https://www.youtube.com/watch?v=Z0Iwtyajih8

@nguyenquocdat30

This comment has been minimized.

Copy link

nguyenquocdat30 commented Apr 5, 2018

Ohh . sorry . it private .

Click here : https://www.youtube.com/watch?v=Z0Iwtyajih8
You can use server instead :
DEFAULT_SERVERS = {
'electrum-verge.xyz':{'t':'50001', 's':'50002'},
'electrum-xvg.stream':{'t':'50001', 's':'50002'},
'electrum-xvg.party':{'t':'50001', 's':'50002'},
'e1.verge-electrum.com':{'t':'50001', 's':'50002'},
'e2.verge-electrum.com':{'t':'50001', 's':'50002'},
'e3.verge-electrum.com':{'t':'50001', 's':'50002'}
}
i hope it helps you :D

@undersun1

This comment has been minimized.

Copy link

undersun1 commented Sep 14, 2018

Just having the Tor browser open on your desktop solves all the "not connected" issues. Somehow, the XVG Electrum Tor wallet is using the Tor connection that is established through the Tor browser when you open it. Problem solved!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment