Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CI is failing on CPAN installs #1508

Closed
veripoolbot opened this issue Sep 17, 2019 · 2 comments
Closed

CI is failing on CPAN installs #1508

veripoolbot opened this issue Sep 17, 2019 · 2 comments

Comments

@veripoolbot
Copy link

@veripoolbot veripoolbot commented Sep 17, 2019


Author Name: Todd Strader (@toddstrader)
Original Redmine Issue: 1508 from https://www.veripool.org

Original Assignee: Todd Strader (@toddstrader)


Travis jobs are failing while installing CPAN modules:

The command "yes yes | sudo cpan -fi Unix::Processors Parallel::Forker Bit::Vector" failed and exited with 8 during .

I'm restarting a few jobs to see how stable the failures are:
https://travis-ci.com/verilator/verilator/builds/127979612
https://travis-ci.com/verilator/verilator/builds/127932280

If it's stable, I'll fix it. If not I may have to add some debug to track it.

@veripoolbot

This comment has been minimized.

Copy link
Author

@veripoolbot veripoolbot commented Sep 17, 2019


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2019-09-17T13:28:20Z


Note CPAN listed Parallel::Forker but it didn't seem to find it in Travis. This morning I tried pushing a new Parallel::Forker release just to see if that would help, didn't look if it did or not yet.

@veripoolbot

This comment has been minimized.

Copy link
Author

@veripoolbot veripoolbot commented Sep 17, 2019


Original Redmine Comment
Author Name: Todd Strader (@toddstrader)
Original Date: 2019-09-17T14:53:17Z


OK, great. I didn't look closely enough at the log before, but now I see:

Warning: Cannot install Parallel::Forker, don't know what it is.
Try the command
     i /Parallel::Forker/
to find objects with matching identifiers.

The jobs are passing now so either that fixed it or it was some other transient CPAN issue. But since the error message (albeit in the middle of the log) does tell us what to do, I think we're good here.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.