Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fuzzer: Segfault with no diagnostic with "--coverage" and different widths #1587

Closed
veripoolbot opened this issue Nov 4, 2019 · 1 comment
Closed

Comments

@veripoolbot
Copy link

@veripoolbot veripoolbot commented Nov 4, 2019


Author Name: Eric Rippey
Original Redmine Issue: 1587 from https://www.veripool.org

Original Assignee: Wilson Snyder (@wsnyder)


Running the attached testcase with:

verilator_bin --lint-only --coverage 5.sv

On version:

Verilator 4.020 devel rev v4.020-56-gbcb766b

Produces a segmentation fault and no other output.

It seems like this may have a similar root cause as #�. However, there are a few differences:

  1. This one is just comparing wires rather than memories
  2. This one requires "--coverage"
  3. There is no diagnostic given in this case
  4. This is a shorter testcase and uses fewer language features.
@veripoolbot

This comment has been minimized.

Copy link
Author

@veripoolbot veripoolbot commented Nov 5, 2019


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2019-11-05T02:41:50Z


Same root cause as #�.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.