Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Signal declarations in for loops don't work everywhere #205

Closed
veripoolbot opened this issue Jan 19, 2010 · 2 comments
Closed

Signal declarations in for loops don't work everywhere #205

veripoolbot opened this issue Jan 19, 2010 · 2 comments

Comments

@veripoolbot
Copy link
Contributor

@veripoolbot veripoolbot commented Jan 19, 2010


Author Name: Byron Bradley (@bbradley)
Original Redmine Issue: 205 from https://www.veripool.org
Original Date: 2010-01-19
Original Assignee: Byron Bradley (@bbradley)


If a signal is declared in a for loop after something that called VARRESET(), it will attempt to create a signal with UNKNOWN type. I think the solution here is to just put a varRESET in the initialization of the for loop. Patch attached.

@veripoolbot
Copy link
Contributor Author

@veripoolbot veripoolbot commented Jan 20, 2010


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2010-01-20T00:33:39Z


Applied to git, thanks for the patch!

@veripoolbot
Copy link
Contributor Author

@veripoolbot veripoolbot commented Feb 7, 2010


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2010-02-07T12:42:15Z


In 3.800.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.