Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

internal error about broken link #958

Closed
veripoolbot opened this issue Aug 18, 2015 · 3 comments
Closed

internal error about broken link #958

veripoolbot opened this issue Aug 18, 2015 · 3 comments
Assignees

Comments

@veripoolbot
Copy link

@veripoolbot veripoolbot commented Aug 18, 2015


Author Name: Jie Xu (@jiexu)
Original Redmine Issue: 958 from https://www.veripool.org
Original Date: 2015-08-18
Original Assignee: Wilson Snyder (@wsnyder)


module test(addr, res);

input [31:0] addr;
output [15:0] res;

  memory i_mem(.addr(addr),.dout(res));

assign i_mem.cxrow_inst[0].cmem_xrow[0] = 16'h0;

endmodule



module memory(addr, dout);
parameter CM_XROWSIZE = 256;
parameter CM_NUMXROWS = 2;

input [31:0] addr;
output [15:0] dout;


  generate
       genvar g_cx;

       // Code (flash) xrows.
       for (g_cx = 0; g_cx < CM_NUMXROWS; g_cx++)
         begin: cxrow_inst
            reg[15:0] cmem_xrow[0:CM_XROWSIZE - 1];
         end
    endgenerate

 assign dout = cxrow_inst[0].cmem_xrow[addr];
endmodule


When compiling the above code, Verilator gives the following error:

%Error: Internal Error: t/t_xref_gen_mem.v:21: ../V3Broken.cpp:216: Broken link in node (or something without maybePointedTo): m_varp && !m_varp->brokeExists()
%Error: Internal Error: See the manual and http://www.veripool.org/verilator for more assistance.


@veripoolbot

This comment has been minimized.

Copy link
Author

@veripoolbot veripoolbot commented Aug 18, 2015


Original Redmine Comment
Author Name: Jie Xu (@jiexu)
Original Date: 2015-08-18T12:12:43Z


Test attached.

Have looked into this, seems Verilator will try link the @Astvar@ for @AstVarXRef@. But in the end in V3Scope.cpp the referenced @varp@ is set to @null@ again.

@veripoolbot

This comment has been minimized.

Copy link
Author

@veripoolbot veripoolbot commented Sep 19, 2015


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2015-09-19T00:59:26Z


Fixed in git towards 3.877.

One of those I tried to fix and found very complicated, then later found an easy fix!

@veripoolbot

This comment has been minimized.

Copy link
Author

@veripoolbot veripoolbot commented Nov 1, 2015


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2015-11-01T13:22:47Z


In 3.878.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.