Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

vppreproc --debug option does not enable debug messages for VCS-like parameters #442

Closed
veripoolbot opened this issue Feb 22, 2012 · 4 comments
Closed
Assignees

Comments

@veripoolbot
Copy link
Collaborator

@veripoolbot veripoolbot commented Feb 22, 2012


Author Name: Jeremy Bennett (@jeremybennett)
Original Redmine Issue: 442 from https://www.veripool.org
Original Date: 2012-02-22
Original Assignee: Wilson Snyder (@wsnyder)


The code for this command contains a number of debug print statements intended to be turned on if vppreproc is called with --Debug as an option.

However Verilog::Getopt::parameter is called to extract VCS-like parameters before the main call to GetOptions which parses parameters like --Debug. As a consequence debug messages associated with parsing VCS-like parameters can never be printed.

I found this when trying to debug a problem with the -f option. @vppreproc --debug -f foo.f@ is intended to print the message @"*parameter_file $filename\n"@, but does not do so.

Test case to follow shortly.

@veripoolbot

This comment has been minimized.

Copy link
Collaborator Author

@veripoolbot veripoolbot commented Feb 22, 2012


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2012-02-22T19:36:41Z


No need for a test, easy to recreate. Fixed in git towards 3.314(159 :).

However note that Verilog::Getopt's $Debug isn't the same as the script's $Debug, so fixing this alone won't get you that message. In vppreproc's "sub debug" you need to add "$Verilog::Getopt::Debug = 1;"

@veripoolbot

This comment has been minimized.

Copy link
Collaborator Author

@veripoolbot veripoolbot commented Feb 23, 2012


Original Redmine Comment
Author Name: Jeremy Bennett (@jeremybennett)
Original Date: 2012-02-23T15:08:21Z


Thanks for the fix. I note that you left the assignment to $Verilog::Getopt::Debug = 1; commented out in vppreproc's sub debug. Was that deliberate?

@veripoolbot

This comment has been minimized.

Copy link
Collaborator Author

@veripoolbot veripoolbot commented Feb 23, 2012


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2012-02-23T16:33:36Z


Actually no, but now that it's there I'll probably leave it.

@veripoolbot

This comment has been minimized.

Copy link
Collaborator Author

@veripoolbot veripoolbot commented Feb 27, 2012


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2012-02-27T13:34:47Z


In 3.314.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.