Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bison 2.4 error on VParseBison_pretmp.y #73

Closed
veripoolbot opened this issue Mar 31, 2009 · 2 comments
Closed

Bison 2.4 error on VParseBison_pretmp.y #73

veripoolbot opened this issue Mar 31, 2009 · 2 comments
Labels

Comments

@veripoolbot
Copy link
Collaborator

@veripoolbot veripoolbot commented Mar 31, 2009


Author Name: Jithendra Madala
Original Redmine Issue: 73 from https://www.veripool.org
Original Date: 2009-03-31


I am not sure whether it is a bison issue or the issue with the VParseBison_pretmp.y. Please take a look.

/mips/proj/tools/perl/5.8.9/bin/perl bisonpre --yacc bison --debug --verbose --d -k VParseBison.y -o VParseBison.c
edit VParseBison.y VParseBison_pretmp.y
bison -t -d -k -v --report=itemset --report=lookahead -p VParseBison_pretmp -b VParseBison_pretmp -o VParseBison_pretmp.c VParseBison_pretmp.y/mips/proj/tools/bison/2.4/share/bison/yacc.c:158: /usr/bin/m4: Warning: Excess arguments to built-in _m4_popdef' ignored /mips/proj/tools/bison/2.4/share/bison/yacc.c:1071: /usr/bin/m4: Warning: Excess arguments to built-in _m4_popdef' ignored
NONE:0: /usr/bin/m4: ERROR: EOF in string
bison: subsidiary program /usr/bin/m4' failed (exit status 1) bisonpre: %Error: bison version 2.4 run failed due to errors make[1]: *** [VParseBison.cpp] Error 9 make[1]: Leaving directory /mips/proj/tools/downloads/veripool/Verilog-Perl-3.120/Parser'

I am using perl/5.8.9, bison/2.4

For now I switched to bison/2.2 and it seems working fine.

m4 --version
GNU m4 1.4.1

uname -a
Linux mipscs284.mips.com 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686 i686 i386 GNU/Linux

Red Hat Enterprise Linux AS release 4 (Nahant Update 4)

Thanks
Jithendra Madala

@veripoolbot

This comment has been minimized.

Copy link
Collaborator Author

@veripoolbot veripoolbot commented Mar 31, 2009


Original Redmine Comment
Author Name: Jithendra Madala
Original Date: 2009-03-31T17:46:48Z


I forgot to mention the version of Verilog-Perl. It is Verilog-Perl-3.120.

@veripoolbot

This comment has been minimized.

Copy link
Collaborator Author

@veripoolbot veripoolbot commented Mar 31, 2009


Original Redmine Comment
Author Name: Wilson Snyder (@wsnyder)
Original Date: 2009-03-31T19:10:38Z


Yes, seems a bison or related problem, certainly nothing I can fix. Glad the other version worked.

BTW are you using a Mac or NetBSD? Googling that error shows those systems have had that problem before, for example:

http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=40329

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.