Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fix problems with pip install

  • Loading branch information...
commit a2172bc0a7e4324f8a2164b56cf778d0c38a4094 1 parent ba9156b
@versae authored
View
8 CHANGES.txt
@@ -1,13 +1,11 @@
Changes
=======
-2.1.1 (2014-11-16)
+2.1.0 (2014-11-17)
------------------
+- Fix pip install error
+- Remove lucene-querybuilder as dependency
- Add stats for query execution
-
-
-2.1.0 (2014-11-09)
-------------------
- Add support for resultDataContents param in the transactional Cypher endpoint
- Fix #116. Although the old reference is still kept, the object does not exist
in server and will fail
View
7 docs/changes.rst
@@ -1,13 +1,12 @@
Changes
=======
-2.1.1 (2014-11-16)
-------------------
-- Add stats for query execution
-
2.1.0 (2014-11-09)
------------------
+- Fix pip install error
+- Remove lucene-querybuilder as dependency
+- Add stats for query execution
- Add support for resultDataContents param in the transactional Cypher endpoint
- Fix #116. Although the old reference is still kept, the object does not exist
in server and will fail
View
4 neo4jrestclient/__init__.py
@@ -1,4 +0,0 @@
-from neo4jrestclient.client import (
- GraphDatabase, Incoming, Outgoing, Undirected,
- StopAtDepth, NotFoundError, StatusException, Q
-)
View
7 neo4jrestclient/client.py
@@ -6,7 +6,12 @@
import pickle
import weakref
import warnings
-from lucenequerybuilder import Q
+try:
+ from lucenequerybuilder import Q
+except:
+ class Q(object):
+ def __init__(self, *args, **kwargs):
+ raise ImportError("Try installing lucene-querybuilder first.")
from neo4jrestclient import options
from neo4jrestclient.constants import (
View
2  neo4jrestclient/constants.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
__author__ = "Javier de la Rosa"
__license__ = "GPL 3"
-__version__ = "2.1.1"
+__version__ = "2.1.0"
__email__ = "versae@gmail.com"
__url__ = "https://github.com/versae/neo4j-rest-client"
__description__ = """Object-oriented Python library to interact with """ \
View
2  setup.py
@@ -14,6 +14,7 @@ def read(*rnames):
tests_require = [
'lockfile>=0.9.1',
'CacheControl>=0.9.2',
+ 'lucene-querybuilder>=0.2',
]
setup(
@@ -43,7 +44,6 @@ def read(*rnames):
include_package_data=True,
install_requires=[
'requests>=2.1.0',
- 'lucene-querybuilder>=0.2',
],
tests_require=tests_require,
test_suite='neo4jrestclient.tests',
Please sign in to comment.
Something went wrong with that request. Please try again.