New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump required PHP version to 5.6+ #726

Closed
borekb opened this Issue Feb 17, 2016 · 0 comments

Comments

Projects
None yet
2 participants
@borekb
Copy link
Member

borekb commented Feb 17, 2016

We started with the mindset of "support as many WP installs as possible" and wanted to support even PHP 5.2 as WordPress itself does. That quickly turned out to be nearly impossible but we at least we tried to support PHP 5.3 for as long as possible. However, even that is largely inconvenient and we're constantly fighting it. For example, we're now working on a custom merge driver (#588) where we need to use the PHP_BINARY constant but is only available since PHP 5.4. There are more examples like that.

So for VersionPress 3.0, we're dropping support for old, unsupported version of PHP and 5.6+ or 7.0 will be required. We're probably not going to upgrade our codebase to use the newest language features yet but the RequirementsChecker will check that the host runs on a supported version of PHP.

Things to do:

  • Update RequirementsChecker
  • Create an issue for docs – versionpress/docs#13
  • Update PhpStorm template files to use a higher language level
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment