obsolete? #2

Closed
dodo opened this Issue Jan 13, 2012 · 4 comments

3 participants

@dodo

for node >=0.5 this is exaclty the same:

require('./package.json')
require('word/package.json')

:)

@vesln
Owner

Yeah. Do not use this module. Back then I thought it's a good idea, but it's just another useless dependency. As soon as I find some free time I will remove it from my modules.

@vesln
Owner

require('./package.json').version is way more expressive :)

@isaacs

If you want to get all the semantics that npm uses when loading package.json files (including loading from comments in a js file, pulling in the readme, checking for misspellings, etc.) then use the read-package-json module.

@vesln
Owner

@isaacs Awesome! I just put deprecation notice in the readme file.

@vesln vesln closed this Jan 3, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment