Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update to new version causes error #17

Closed
germanvaleroelizondo opened this issue Feb 17, 2019 · 16 comments

Comments

Projects
None yet
2 participants
@germanvaleroelizondo
Copy link

commented Feb 17, 2019

When upgrading to the new versiontoday, I got the following error:

Warning: require_once(/Warning: require_once(/var/www/html/lib/eventslib.php): failed to open stream: No such file or directory in /var/www/html/mod/flashcard/lib.php on line 29): failed to open stream: No such file or directory in /var/www/html/mod/flashcard/lib.php on line 29

I can not create a new empty lib\eventslib.php file today.
I can not comment out line 29 in lib.php.

I will need to ask the IT guys at my University tomorrow.

Paul Powell wrote on 8 January 2019, 04:31 "Installed this for 3.6 today and it causes a nasty whitescreen for the whole site. This is due to /lib/eventslib.php being required by lib.php. Commenting out this line (29 in lib.php) gets it working. Furthermore, another (less serious) error is caused by line 170 of renderer.php. This stops the user overview from being displayed. $OUTPUT->pix_icon needs changing to $this->output->pix_icon."

@vfremaux

This comment has been minimized.

Copy link
Owner

commented Feb 17, 2019

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Feb 18, 2019

Modflashcard 3.5.0 (Build 2019011000) 2018120600
in a server with Moodle 3.6.2+ (Build: 20190118)
PHP Version 7.2.14

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Feb 18, 2019

Hi Valery,

The IT guy at my University commented out the line described and the server works again.

But I fear many more Moodlers might suffer from the same problem.

@vfremaux

This comment has been minimized.

Copy link
Owner

commented Feb 19, 2019

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Feb 19, 2019

Hi Valery,
The current problem can be easily reproduced:

A new empty local Moodle 3.6.2+ (Build: 20190208) server, PHP Version 7.1.10

When I install from the Moodle plugins database, choosig the version for Moodle 3.6, it causes a white screen freeze.

install flashcard from moodle plugins database for m36

And the plugin does have the culprit line:

require_once($CFG->libdir.'/eventslib.php');

@vfremaux

This comment has been minimized.

Copy link
Owner

commented Feb 19, 2019

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Feb 19, 2019

Hi Valery,

Do you know when will the Moodle plugins database have the right versions ?

@vfremaux

This comment has been minimized.

Copy link
Owner

commented Feb 20, 2019

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Feb 23, 2019

I installed from Moodle plugins database,

but I got $plugin->version = 2019011000; // The current module version (Date: YYYYMMDDXX):

Warning: require_once(C:\Temp\m_3_6_2_plus\server\moodle/lib/eventslib.php): failed to open stream: No such file or directory in C:\Temp\m_3_6_2_plus\server\moodle\mod\flashcard\lib.php on line 29

Fatal error: require_once(): Failed opening required 'C:\Temp\m_3_6_2_plus\server\moodle/lib/eventslib.php' (include_path='C:\Temp\m_3_6_2_plus\server\moodle/lib/pear;C:\Temp\m_3_6_2_plus\server\php\PEAR') in C:\Temp\m_3_6_2_plus\server\moodle\mod\flashcard\lib.php on line 29

BUT, if instead of installing from the Moodle plugins database, I download the ZIP file for Moodle 3.6, it will download the correct file 3.6.0 (Build 2019011000)

THE PROBLEM seems to be that the Moodle plugins database page in https://moodle.org/plugins/mod_flashcard shows automatically
Release 3.5.0 (Build 2019011000)

and if i try to install now from there 3.6.0 (Build 2019011000) (2019011000)Moodle 3.6, choosing my 3.6 server,
it will automatically WRONGFULLY attempt to install this 3,5 version:

[OK] Nombre del plugin que será instalado [flashcard]

[OK] Versión del plugin [2019011000]
[OK] Versión de Moodle requerida [2018042700]
[OK] Nombre completo del componente [mod_flashcard]
[OK] Nivel de madurez declarado [MATURITY_STABLE]

[OK] Lote del plugin [3.5.0 (Build 2019011000)]
[Depuración (debug)] Se encontró archivo de idioma [flashcard]
[OK] Revisión de acceso de escritura [C:\Temp\m_3_6_2_plus\server\moodle/mod]

Validación exitosa, la instalación puede continuar

AND it will freeze my server.

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Feb 23, 2019

SO, the problem is that the Moodle plugins database by default will offer the 3.5 version only for 3.5.

It should instead offer a version for all supported Moodle branches. See https://moodle.org/plugins/atto_cloze

bad versions offered

good versions offered

@vfremaux

This comment has been minimized.

Copy link
Owner

commented Feb 24, 2019

@vfremaux

This comment has been minimized.

Copy link
Owner

commented Feb 24, 2019

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Mar 2, 2019

I did choose the 3.6 version.

I just saw the exact same wrong behaviour seen in your Flashcards set (https://moodle.org/plugins/mod_flashcard)

with the new trema theme (https://moodle.org/plugins/theme_trema)

And google analytics (https://moodle.org/plugins/pluginversions.php?plugin=local_ganalytics)

Restriction by cohort (https://moodle.org/plugins/availability_cohort)

Knowledge sharing (https://moodle.org/plugins/block_knowledge_sharing)

User bulk enrolment (https://moodle.org/plugins/pluginversions.php?plugin=local_bulkenrol)

Course completed ewnrolment (https://moodle.org/plugins/pluginversions.php?plugin=enrol_coursecompleted)

Microsoft onedrive document converter (https://moodle.org/plugins/pluginversions.php?plugin=fileconverter_onedrive)

The foundation theme (https://moodle.org/plugins/theme_foundation)

The last two plugins do not show ANY Moodle branch supported, even though they do have a 3.6 compatible version.

With some of these plugins, when I try to install it from the Moodle plugins database in my 3.6.2 server, it downloads the 3.5 version instead.

Maybe we should contact David Mudrak, as this issue now affects several plugins ?

@vfremaux

This comment has been minimized.

Copy link
Owner

commented Mar 3, 2019

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Mar 4, 2019

I just posted on the Moodle developer forum at https://moodle.org/mod/forum/discuss.php?d=383331.

@germanvaleroelizondo

This comment has been minimized.

Copy link
Author

commented Apr 2, 2019

I have finally figured it out.
Silly old me :(
Problem solved, issue closed.

See https://moodle.org/mod/forum/discuss.php?d=383331#p1550506

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.