New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dub.json parse errors #1172

Closed
Lord-Evil opened this Issue Jul 6, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@Lord-Evil

Lord-Evil commented Jul 6, 2015

Nor Python, nor JavaScript can understand that the last element in array has coma following it.
e.g.

    "configurations": [
        {
            "name": "libevent",
            "dependencies": {"libevent": "~>2.0.1+2.0.16"},
            "platforms": ["windows-x86", "posix"],
            "versions": ["VibeLibeventDriver"],
            "sourceFiles-windows-x86": ["lib/win-i386/event2.lib"],
            "copyFiles-windows-x86": ["lib/win-i386/libevent.dll"],
            "sourceFiles-windows-x86_64": ["lib/win-amd64/event2.lib"],
            "copyFiles-windows-x86_64": ["lib/win-amd64/libevent.dll"],
            "libs-windows": ["wsock32", "ws2_32", "advapi32"],
        },
"libs-windows": ["wsock32", "ws2_32", "advapi32"],
@Lord-Evil

This comment has been minimized.

Show comment
Hide comment
@Lord-Evil

Lord-Evil Jul 6, 2015

It goes against JSON specification. Please fix it :-)

Lord-Evil commented Jul 6, 2015

It goes against JSON specification. Please fix it :-)

@s-ludwig s-ludwig closed this in 606177c Jul 7, 2015

@s-ludwig

This comment has been minimized.

Show comment
Hide comment
@s-ludwig
Member

s-ludwig commented Jul 7, 2015

See also dlang/dub#415

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment