New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Does not compile on recent Debian versions because of openssl brokenness #1315

Closed
lultimouomo opened this Issue Nov 2, 2015 · 0 comments

Comments

Projects
None yet
1 participant
@lultimouomo
Contributor

lultimouomo commented Nov 2, 2015

It appears that Debian has removed SSLv3_client_method, SSLv3_server_method and SSLv3_method from OpenSSL, so vibe.d fails to build on Debian; see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=768476
I'll be sending a PR shortly using SSLv23 methods with the appropriate options instead.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment