Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Update linux install script to use RubyGems 1.3.7

git-svn-id: https://svn.apache.org/repos/asf/buildr/trunk@980970 13f79535-47bb-0310-9956-ffa450edef68
  • Loading branch information...
commit 36ab7a581e97e9ac52630e783b685672a1063753 1 parent 241d505
Alex Boisvert authored
Showing with 7 additions and 6 deletions.
  1. +7 −6 doc/scripts/install-linux.sh
View
13 doc/scripts/install-linux.sh
@@ -24,15 +24,15 @@ if [ -z `which ruby` ] ; then
echo "Installing Ruby using apt-get"
# ruby package does not contain RDoc, IRB, etc; ruby-full is a meta-package.
# build-essentials not installed by default in Ubuntu, required for C extensions.
- sudo apt-get install ruby-full ruby1.8-dev libopenssl-ruby build-essential
+ sudo apt-get install ruby-full ruby1.8-dev libopenssl-ruby build-essential
# RubyGems broken on Ubuntu, installing directly from source.
echo "Installing RubyGems from RubyForge"
- wget http://rubyforge.org/frs/download.php/45905/rubygems-1.3.1.tgz
- tar xzf rubygems-1.3.1.tgz
- cd rubygems-1.3.1
+ wget http://production.cf.rubygems.org/rubygems/rubygems-1.3.7.tgz
+ tar xzf rubygems-1.3.7.tgz
+ cd rubygems-1.3.7
sudo ruby setup.rb
cd ..
- rm -rf rubygems-1.3.1
+ rm -rf rubygems-1.3.7
# ruby is same as ruby1.8, we need gem that is same as gem1.8
sudo ln -s /usr/bin/gem1.8 /usr/bin/gem
elif [ `which urpmi` ] ; then
@@ -54,9 +54,10 @@ if [ -z $JAVA_HOME ] ; then
exit 1
fi
-if [ $(gem --version) \< '1.3.1' ] ; then
+if [ $(gem --version) \< '1.3.7' ] ; then
echo "Upgrading to latest version of RubyGems"
sudo gem update --system
+ sudo update_rubygems
echo
fi
Please sign in to comment.
Something went wrong with that request. Please try again.