Permalink
Browse files

Adding SimpleCov support and updating gems

  • Loading branch information...
1 parent b9463c5 commit d6b5c2979b2a1f25f281aa199c73c2b58bd8015e @vicentemundim committed Mar 29, 2011
Showing with 34 additions and 18 deletions.
  1. +2 −0 .gitignore
  2. +1 −0 Gemfile
  3. +22 −18 Gemfile.lock
  4. +9 −0 spec/spec_helper.rb
View
@@ -1,3 +1,5 @@
.DS_Store
.bundle
+.rvmrc
+coverage
*.gem
View
@@ -12,4 +12,5 @@ end
platforms :mri_19 do
gem "ruby-debug19", :require => 'ruby-debug' if RUBY_VERSION < "1.9.3"
+ gem 'simplecov', :require => false
end
View
@@ -8,39 +8,39 @@ PATH
GEM
remote: http://rubygems.org/
specs:
- activemodel (3.0.3)
- activesupport (= 3.0.3)
+ activemodel (3.0.5)
+ activesupport (= 3.0.5)
builder (~> 2.1.2)
i18n (~> 0.4)
- activesupport (3.0.3)
+ activesupport (3.0.5)
archive-tar-minitar (0.5.2)
- bson (1.2.0)
- bson_ext (1.2.0)
+ bson (1.2.4)
+ bson_ext (1.2.4)
builder (2.1.2)
columnize (0.3.2)
- database_cleaner (0.6.1)
+ database_cleaner (0.6.6)
diff-lcs (1.1.2)
i18n (0.5.0)
- json (1.4.6)
+ json (1.5.1)
linecache (0.43)
linecache19 (0.5.11)
ruby_core_source (>= 0.1.4)
- mongo (1.2.0)
- bson (>= 1.2.0)
- mongoid (2.0.0.rc.7)
+ mongo (1.2.4)
+ bson (>= 1.2.4)
+ mongoid (2.0.0.rc.8)
activemodel (~> 3.0)
mongo (~> 1.2)
tzinfo (~> 0.3.22)
will_paginate (~> 3.0.pre)
rake (0.8.7)
- rspec (2.4.0)
- rspec-core (~> 2.4.0)
- rspec-expectations (~> 2.4.0)
- rspec-mocks (~> 2.4.0)
- rspec-core (2.4.0)
- rspec-expectations (2.4.0)
+ rspec (2.5.0)
+ rspec-core (~> 2.5.0)
+ rspec-expectations (~> 2.5.0)
+ rspec-mocks (~> 2.5.0)
+ rspec-core (2.5.1)
+ rspec-expectations (2.5.0)
diff-lcs (~> 1.1.2)
- rspec-mocks (2.4.0)
+ rspec-mocks (2.5.0)
ruby-debug (0.10.4)
columnize (>= 0.1)
ruby-debug-base (~> 0.10.4.0)
@@ -56,7 +56,10 @@ GEM
ruby-debug-base19 (>= 0.11.19)
ruby_core_source (0.1.4)
archive-tar-minitar (>= 0.5.2)
- tzinfo (0.3.24)
+ simplecov (0.4.1)
+ simplecov-html (~> 0.4.3)
+ simplecov-html (0.4.3)
+ tzinfo (0.3.25)
will_paginate (3.0.pre2)
PLATFORMS
@@ -73,3 +76,4 @@ DEPENDENCIES
rspec (>= 2.3.0)
ruby-debug
ruby-debug19
+ simplecov
View
@@ -7,6 +7,15 @@
exit 1
end
+begin
+ require 'simplecov'
+
+ SimpleCov.start
+ SimpleCov.coverage_dir 'coverage'
+rescue LoadError
+ # ignore simplecov in ruby < 1.9
+end
+
# Requires supporting files with custom matchers and macros, etc,
# in ./support/ and its subdirectories.
Dir[File.expand_path('support/**/*.rb', File.dirname(__FILE__))].each { |f| require f }

0 comments on commit d6b5c29

Please sign in to comment.