Permalink
Browse files

nodejs cookbook: fix conditional rules and update node/npm to latest …

…versions
  • Loading branch information...
1 parent 0dde7a2 commit a880cf4e66b5b1679fe1ae350bb02a19bbee9d57 @mdxp mdxp committed Nov 3, 2010
Showing with 37 additions and 37 deletions.
  1. +2 −2 attributes/default.rb
  2. +32 −32 metadata.json
  3. +1 −1 metadata.rb
  4. +1 −1 recipes/default.rb
  5. +1 −1 recipes/npm.rb
View
@@ -17,6 +17,6 @@
# limitations under the License.
#
-default.nodejs[:version] = "0.2.2"
+default.nodejs[:version] = "0.2.4"
default.nodejs[:dir] = "/usr/local"
-default.nodejs[:npm] = "0.1.27-12"
+default.nodejs[:npm] = "0.2.5-1"
View
@@ -1,34 +1,34 @@
{
- "recipes": {
- "nodejs::npm": "Installs npm - a package manager for node",
- "nodejs": "Installs Node.JS from source"
- },
- "replacing": {
- },
- "attributes": {
- },
- "maintainer_email": "marius@promethost.com",
- "groupings": {
- },
- "dependencies": {
- "build-essential": [
+ "conflicting": {
+ },
+ "long_description": "= DESCRIPTION:\n\nInstalls Node.JS from source.\n\n= REQUIREMENTS:\n\n== Platform:\n\nTested on Debian Lenny. Should work fine on Ubuntu, Centos, etc.\n\n== Cookbooks:\n\nOpscode cookbooks (http://github.com/opscode/cookbooks/tree/master)\n\n* build-essential\n\n= ATTRIBUTES:\n\n* nodejs[:version] - release version of node to install\n* nodejs[:dir] - location where node will be installed, default /usr/local\n* nodejs[:npm] - version of npm to install\n\n= USAGE:\n\nInclude the nodejs recipe to install node from source on your system:\n\n include_recipe \"nodejs\"\n\nInclude the npm recipe to install npm:\n \n include_recipe \"nodejs::npm\"\n\n= LICENSE and AUTHOR:\n\nAuthor:: Marius Ducea (marius@promethost.com)\n\nCopyright:: 2010, Promet Solutions\n\nLicensed under the Apache License, Version 2.0 (the \"License\");\nyou may not use this file except in compliance with the License.\nYou may obtain a copy of the License at\n\n http://www.apache.org/licenses/LICENSE-2.0\n\nUnless required by applicable law or agreed to in writing, software\ndistributed under the License is distributed on an \"AS IS\" BASIS,\nWITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\nSee the License for the specific language governing permissions and\nlimitations under the License.\n",
+ "recipes": {
+ "nodejs::npm": "Installs npm - a package manager for node",
+ "nodejs": "Installs Node.JS from source"
+ },
+ "attributes": {
+ },
+ "providing": {
+ },
+ "dependencies": {
+ "build-essential": [
- ]
- },
- "recommendations": {
- },
- "long_description": "= DESCRIPTION:\n\nInstalls Node.JS from source.\n\n= REQUIREMENTS:\n\n== Platform:\n\nTested on Debian Lenny. Should work fine on Ubuntu, Centos, etc.\n\n== Cookbooks:\n\nOpscode cookbooks (http://github.com/opscode/cookbooks/tree/master)\n\n* build-essential\n\n= ATTRIBUTES:\n\n* nodejs[:version] - release version of node to install\n* nodejs[:dir] - location where node will be installed, default /usr/local\n* nodejs[:npm] - version of npm to install\n\n= USAGE:\n\nInclude the nodejs recipe to install node from source on your system:\n\n include_recipe \"nodejs\"\n\nInclude the npm recipe to install npm:\n \n include_recipe \"nodejs::npm\"\n\n= LICENSE and AUTHOR:\n\nAuthor:: Marius Ducea (marius@promethost.com)\n\nCopyright:: 2010, Promet Solutions\n\nLicensed under the Apache License, Version 2.0 (the \"License\");\nyou may not use this file except in compliance with the License.\nYou may obtain a copy of the License at\n\n http://www.apache.org/licenses/LICENSE-2.0\n\nUnless required by applicable law or agreed to in writing, software\ndistributed under the License is distributed on an \"AS IS\" BASIS,\nWITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\nSee the License for the specific language governing permissions and\nlimitations under the License.\n",
- "suggestions": {
- },
- "platforms": {
- },
- "license": "Apache 2.0",
- "version": "0.1.1",
- "conflicting": {
- },
- "name": "nodejs",
- "providing": {
- },
- "description": "Installs/Configures nodejs",
- "maintainer": "Promet Solutions"
- }
+ ]
+ },
+ "maintainer": "Promet Solutions",
+ "replacing": {
+ },
+ "platforms": {
+ },
+ "license": "Apache 2.0",
+ "maintainer_email": "marius@promethost.com",
+ "version": "0.2.0",
+ "groupings": {
+ },
+ "recommendations": {
+ },
+ "name": "nodejs",
+ "suggestions": {
+ },
+ "description": "Installs/Configures nodejs"
+}
View
@@ -3,7 +3,7 @@
license "Apache 2.0"
description "Installs/Configures nodejs"
long_description IO.read(File.join(File.dirname(__FILE__), 'README.rdoc'))
-version "0.1.3"
+version "0.2.0"
recipe "nodejs", "Installs Node.JS from source"
recipe "nodejs::npm", "Installs npm - a package manager for node"
View
@@ -38,6 +38,6 @@
make && \
make install
EOH
- not_if {File.exists?("/usr/local/src/node-v#{node[:nodejs][:version]}/node")}
+ not_if do `#{node[:nodejs][:dir]}/bin/node -v`.include? "v#{node[:nodejs][:version]}" end
end
View
@@ -29,6 +29,6 @@
curl -L http://github.com/isaacs/npm/tarball/v#{node[:nodejs][:npm]} | tar xzf - --strip-components=1 && \
make uninstall install
EOH
- not_if {File.exists?("/usr/local/bin/npm-#{node[:nodejs][:npm]}")}
+ not_if {File.exists?("/usr/local/bin/npm@#{node[:nodejs][:npm]}")}
end

0 comments on commit a880cf4

Please sign in to comment.