Skip to content
This repository has been archived by the owner. It is now read-only.

Windows 10 IE not Edge not woking #1011

Closed
WeBBLiu opened this issue Feb 15, 2017 · 8 comments
Closed

Windows 10 IE not Edge not woking #1011

WeBBLiu opened this issue Feb 15, 2017 · 8 comments

Comments

@WeBBLiu
Copy link

@WeBBLiu WeBBLiu commented Feb 15, 2017

Description
win10 IE video.js play m3u8 not woking , but chrome edge fine.

Sources
<video id='myvideo' controls preload='auto' class='video-js vjs-default-skin vjs-16-9 vjs-big-play-centered' >
<source src='http://vod.streamingfast.net/hls-vod/dvr/ch1.20170215_0200.m3u8' type='application/x-mpegURL'></video>

videojs-contrib-hls version
v5.2.1

videojs version
5.17.0

Browsers
Win10
IE not working
Edge working
Chrome working

Platforms
Win10

Other Plugins
none.

Other JavaScript
Jquery

@gkatsev
Copy link
Member

@gkatsev gkatsev commented Feb 15, 2017

Can you please fill out the issue template? Specifically, the sections around which versions of contrib-hls, video.js, and browser and OS.
A reduced test case would be appreciated as well.
Thanks.

@forbesjo
Copy link
Collaborator

@forbesjo forbesjo commented Feb 15, 2017

This may be related to this known issue https://github.com/videojs/videojs-contrib-hls#ie11

@alibrightman
Copy link

@alibrightman alibrightman commented Feb 19, 2017

Windows 7 + IE 11 doesn't work either.
videojs-contrib-hls 5.2.1
Video.js 5.16.0

Test using http://videojs.github.io/videojs-contrib-hls/
Or http://jsbin.com/vokipos/8/edit?html,output
Video is expected to play, but doesn't.

Console errors:

VIDEOJS: WARN: Failed to create SourceBuffers TypeError: Object doesn't support property or method 'vjs_appendChunkReady'

(the debugger breaks at https://unpkg.com/videojs-contrib-hls/dist/videojs-contrib-hls.js Line 9398)

VIDEOJS: ERROR: (CODE:3 MEDIA_ERR_DECODE) The media playback was aborted due to a corruption problem or because the media used features your browser did not support.

@gesinger
Copy link
Collaborator

@gesinger gesinger commented Feb 21, 2017

@elhampour
Copy link

@elhampour elhampour commented Mar 1, 2017

i dont have any error in ie 11 or below, but my videos wont play, maybe i have to use different coding for ts files or some thing else.

What should we do for this problem ?

@forbesjo
Copy link
Collaborator

@forbesjo forbesjo commented Mar 2, 2017

@gesinger I think we should update the known issue note with something like

if ((/Trident\/7.0/i).test(USER_AGENT) && (/rv:11.0/).test(USER_AGENT)) 
  videojs.options.hls.mode = 'flash';
@mjneil
Copy link
Collaborator

@mjneil mjneil commented Apr 12, 2017

@forbesjo I think we should raise an issue with video.js to set videojs.browser.IE_VERSION = 11 when those user agent tests pass

@forbesjo
Copy link
Collaborator

@forbesjo forbesjo commented Oct 30, 2017

videojs.browser.IE_VERSION can be used to detect IE11, in the future we'll be making this override easier.

@forbesjo forbesjo closed this Oct 30, 2017
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants