Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Rails auto complete problem #106

Open
andrewcrook opened this Issue · 6 comments

5 participants

@andrewcrook

I can get ruby syntax to auto complete, however, I cant get it to auto complete anything from the Rails framework. I have "let g:rubycomplete_rails = 1" in my .vimrc and I have checked that the paths are visible from within vim (shims/rails path as using rbenv on ubuntu). I also have rails.vim installed which works fine so I don't think there is an issue regarding finding Rails itself. Any ideas?

@segfault
Owner

What Rails version?

@andrewcrook

versions are

Rails 3.2.8
Ruby 1.9.2p320
Vim 7.3.429 (ubuntu vim-nox package)

@andrewcrook andrewcrook closed this
@andrewcrook andrewcrook reopened this
@mindfulmonk

@andrewcrook did you find a solution?

@andrewcrook

I don't think so. To be honest I got side tracked into a Python project using vim-python and the last Rails project I tested a commercial IDE. I will come back and try again sometime.

@tcuthbert

I'm also experiencing this issue:
Rails 4.0.1
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]
VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Sep 3 2013 19:58:40)

@BeyondIM

I'm also experiencing the same problem on MacVim.
How to debug this? I can paste my debug log to help fixing.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.