fix and reformat installer #153

Merged
merged 2 commits into from Jun 1, 2013

Projects

None yet

2 participants

Contributor

The first of these two commits fixes a deprecation issue which prevented the installer (bin/vim-ruby-installer.rb) from running sucessfully. The second commit simply reformats the file.

Ichimonji10 added some commits May 9, 2013
@Ichimonji10 Ichimonji10 Fix deprecation error.
Without fix, this error message appears:

    bin/vim-ruby-install.rb:15:in `<main>': Use RbConfig instead of obsolete and deprecated Config.

    uninitialized constant Env::CONFIG
    Try 'ruby bin/vim-ruby-install.rb --help' for detailed usage.
bea6026
@Ichimonji10 Ichimonji10 Reformat installer.
Replace tabs with spaces. Ensure comments are properly lined up with code.
f90d7b6
@AndrewRadev AndrewRadev merged commit 6ba4a63 into vim-ruby:master Jun 1, 2013
Member

I see no harm in the pull request, though maybe it's time to remove the installer altogether. I don't have enough confidence to do that, though, so if any other maintainers know what the status of the installer is, maybe now would be a good time to consider it.

Thanks for your work, in any case.

Contributor

:D

Yeah, I was surprised to see such a major issue in this package. If the installer flat-out fails, I suspect many people will not take this package seriously. No installer is better than a broken installer, IMO.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment