Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Version 7.1.3

Added code to allow only one instance of the plugin to run at a time. Thanks Dennis Hostetler.
  • Loading branch information...
commit 0c9b58efa30f57a40fccdfa2186fc7103f055884 1 parent 918ffc0
jeff lanzarotta authored committed
Showing with 14 additions and 10 deletions.
  1. +5 −2 doc/bufexplorer.txt
  2. +9 −8 plugin/bufexplorer.vim
7 doc/bufexplorer.txt
View
@@ -1,7 +1,7 @@
-*bufexplorer.txt* Buffer Explorer Last Change: 02 Nov 2007
+*bufexplorer.txt* Buffer Explorer Last Change: 15 Nov 2007
Buffer Explorer *buffer-explorer* *bufexplorer*
- Version 7.1.2
+ Version 7.1.3
Plugin for easily exploring (or browsing) Vim |:buffers|.
@@ -146,6 +146,9 @@ The default is to split the path and file name.
===============================================================================
CHANGE LOG *bufexplorer-changelog*
+7.1.3 - Fixes:
+ * Added code to allow only one instance of the plugin to run at a
+ time. Thanks Dennis Hostetler.
7.1.2 - Fixes:
* Fixed a jumplist issue spotted by JiangJun. I overlooked the
'jumplist' and with a couple calls to 'keepjumps', everything is
17 plugin/bufexplorer.vim
View
@@ -8,11 +8,11 @@
" event will the copyright holder be liable for any damages
" resulting from the use of this software.
" Name Of File: bufexplorer.vim
-" Description: Buffer Explorer Vim Autoload file
+" Description: Buffer Explorer Vim Plugin
" Maintainer: Jeff Lanzarotta (delux256-vim at yahoo dot com)
-" Last Changed: Monday, 05 November 2007
+" Last Changed: Thursday, 15 November 2007
" Version: See g:bufexplorer_version for version number.
-" Usage: This file should reside in the autoload directory and be
+" Usage: This file should reside in the plugin directory and be
" automatically sourced.
"
" You may use the default keymappings of
@@ -27,15 +27,14 @@
" History: See supplied documentation.
"=============================================================================
-" Check compatibility {{{1
-" Exit quickly when 'compatible' is set.
-if &cp
+" Exit quickly if already running or when 'compatible' is set. {{{1
+if exists("g:bufexplorer_version") || &cp
finish
endif
"1}}}
" Version number
-let g:bufexplorer_version = "7.1.2"
+let g:bufexplorer_version = "7.1.3"
" Check for Vim version 700 or greater {{{1
if v:version < 700
@@ -45,9 +44,11 @@ endif
" Public Interface {{{1
nmap <silent> <unique> <Leader>be :BufExplorer<CR>
+"XXXXX nmap <silent> <unique> <Leader>bs :SBufExplorer<CR>
" Create commands {{{1
-command BufExplorer :call StartBufExplorer(has("gui")?"drop": "hide edit")
+command BufExplorer :call StartBufExplorer(has ("gui") ? "drop" : "hide edit")
+"XXXXX command SBufExplorer :call StartBufExplorer(has ("gui") ? "sp" : "hide edit")
" Set {{{1
function s:Set(var, default)
Please sign in to comment.
Something went wrong with that request. Please try again.