Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Version 1.0.3: Perforce diff was skipping files added via branching

  • Loading branch information...
commit 3b6e443e5c716e60b2c64693dd1341c2c6d37cc9 1 parent 31cd0ba
@junkblocker junkblocker authored committed
View
4 autoload/patchreview.vim
@@ -1,7 +1,7 @@
" VIM plugin for doing single, multi-patch or diff code reviews {{{
" Home: http://www.vim.org/scripts/script.php?script_id=1563
-" Version : 1.0.2 {{{
+" Version : 1.0.3 {{{
" Author : Manpreet Singh < junkblocker@yahoo.com >
" Copyright : 2006-2012 by Manpreet Singh
" License : This file is placed in the public domain.
@@ -9,6 +9,8 @@
"
" Changelog :
"
+" 1.0.3 - Perforce diff was skipping files added via branching
+"
" 1.0.2 - Fix for system's patch command on BSDs.
" - Better exception handling
"
View
2  autoload/patchreview/perforce.vim
@@ -50,7 +50,7 @@ function! s:perforce.GetDiff() " {{{
let l:diff += ['@@ -1,' . len(l:diffl) . ' +0,0 @@']
let l:diff += l:diffl
unlet! l:diffl
- elseif l:line =~ '\(add \(default \)\?change\) .*\(text\|unicode\|utf16\)'
+ elseif l:line =~ '\(\(add\|branch\) \(default \)\?change\) .*\(text\|unicode\|utf16\)'
call s:PRemote.Status('Reading ' . l:fwhere)
let l:diff += ['--- /dev/null']
let l:diff += ['+++ ' . l:fwhere]
View
2  doc/patchreview.txt
@@ -1,5 +1,5 @@
*patchreview.txt* Vim global plugin for doing single, multi-patch or diff code reviews
- Version 1.0.2 (for Vim version 7.0 or higher)
+ Version 1.0.3 (for Vim version 7.0 or higher)
Author: Manpreet Singh < junkblocker@yahoo.com >
Copyright (C) 2006-2011 by Manpreet Singh
View
4 plugin/patchreview.vim
@@ -1,7 +1,7 @@
" VIM plugin for doing single, multi-patch or diff code reviews {{{
" Home: http://www.vim.org/scripts/script.php?script_id=1563
-" Version : 1.0.2 " {{{
+" Version : 1.0.3 " {{{
" Author : Manpreet Singh < junkblocker@yahoo.com >
" Copyright : 2006-2012 by Manpreet Singh
" License : This file is placed in the public domain.
@@ -62,7 +62,7 @@
if &cp || (! exists('g:patchreview_debug') && exists('g:loaded_patchreview'))
finish
endif
-let g:loaded_patchreview="1.0.2"
+let g:loaded_patchreview="1.0.3"
if v:version < 700
echomsg 'patchreview: You need at least Vim 7.0'
finish
Please sign in to comment.
Something went wrong with that request. Please try again.