Permalink
Browse files

Syntastic lives in its own organisation now.

  • Loading branch information...
1 parent 734fde7 commit 7993f7946fc77b7969d961f32233c6dfad361147 @lcd047 lcd047 committed Nov 14, 2016
Showing with 21 additions and 19 deletions.
  1. +4 −4 CONTRIBUTING.md
  2. +12 −10 README.markdown
  3. +2 −2 doc/syntastic-checkers.txt
  4. +2 −2 doc/syntastic.txt
  5. +1 −1 plugin/syntastic.vim
View
@@ -97,9 +97,9 @@ let errorformat =
\ '%-G%.%#'
```
-[bug_tracker]: https://github.com/scrooloose/syntastic/issues
-[manual]: https://github.com/scrooloose/syntastic/blob/master/doc/syntastic.txt
-[github]: https://github.com/scrooloose/syntastic
+[bug_tracker]: https://github.com/vim-syntastic/syntastic/issues
+[manual]: https://github.com/vim-syntastic/syntastic/blob/master/doc/syntastic.txt
+[github]: https://github.com/vim-syntastic/syntastic
[branches]: https://github.com/dchelimsky/rspec/wiki/Topic-Branches#using-topic-branches-when-contributing-patches
[variables]: http://www.refactoring.com/catalog/extractVariable.html
-[guide]: https://github.com/scrooloose/syntastic/wiki/Syntax-Checker-Guide
+[guide]: https://github.com/vim-syntastic/syntastic/wiki/Syntax-Checker-Guide
View
@@ -49,11 +49,12 @@
## 1\. Introduction
-Syntastic is a syntax checking plugin for [Vim][vim] that runs files through
-external syntax checkers and displays any resulting errors to the user. This
-can be done on demand, or automatically as files are saved. If syntax errors
-are detected, the user is notified and is happy because they didn't have to
-compile their code or execute their script to find them.
+Syntastic is a syntax checking plugin for [Vim][vim] created by
+[Martin Grenfell][scrooloose]. It runs files through external syntax checkers
+and displays any resulting errors to the user. This can be done on demand, or
+automatically as files are saved. If syntax errors are detected, the user is
+notified and is happy because they didn't have to compile their code or execute
+their script to find them.
At the time of this writing, syntastic has checking plugins for ACPI
Source Language, ActionScript, Ada, Ansible configurations, API Blueprint,
@@ -153,7 +154,7 @@ You now have pathogen installed and can put syntastic into `~/.vim/bundle` like
this:
```sh
cd ~/.vim/bundle && \
-git clone --depth=1 https://github.com/scrooloose/syntastic.git
+git clone --depth=1 https://github.com/vim-syntastic/syntastic.git
```
Quit vim and start it back up to reload it, then type:
```vim
@@ -501,15 +502,16 @@ plugins that provide more functionality than syntastic. You might want to take
a look at [ghcmod-vim][ghcmod], [jedi-vim][jedi], [python-mode][python_mode], [vim-go][vimgo], or
[YouCompleteMe][ycm].
-[screenshot]: https://github.com/scrooloose/syntastic/raw/master/_assets/screenshot_1.png
+[scrooloose]: https://github.com/scrooloose
+[screenshot]: https://github.com/vim-syntastic/syntastic/raw/master/_assets/screenshot_1.png
-[bug_tracker]: https://github.com/scrooloose/syntastic/issues
-[checkers]: https://github.com/scrooloose/syntastic/blob/master/doc/syntastic-checkers.txt
+[bug_tracker]: https://github.com/vim-syntastic/syntastic/issues
+[checkers]: https://github.com/vim-syntastic/syntastic/blob/master/doc/syntastic-checkers.txt
[crystal]: https://github.com/rhysd/vim-crystal
[eastwood]: https://github.com/venantius/vim-eastwood
[ghcmod]: https://github.com/eagletmt/ghcmod-vim
[google_group]: https://groups.google.com/group/vim-syntastic
-[guide]: https://github.com/scrooloose/syntastic/wiki/Syntax-Checker-Guide
+[guide]: https://github.com/vim-syntastic/syntastic/wiki/Syntax-Checker-Guide
[jedi]: https://github.com/davidhalter/jedi-vim
[merlin]: https://github.com/the-lambda-church/merlin
[myint]: https://github.com/myint/syntastic-extras
@@ -2009,7 +2009,7 @@ Security~
This checker executes the code in the files it checks:
- https://github.com/scrooloose/syntastic/issues/1141
+ https://github.com/vim-syntastic/syntastic/issues/1141
This is probably fine if you wrote the files yourself, but it can be a problem
if you're trying to check third party files. If you are 100% willing to let
@@ -5123,7 +5123,7 @@ Security~
This checker executes the code in the files it checks:
- https://github.com/scrooloose/syntastic/issues/1773
+ https://github.com/vim-syntastic/syntastic/issues/1773
This is probably fine if you wrote the files yourself, but it can be a problem
if you're trying to check third party files. If you are 100% willing to let
View
@@ -85,7 +85,7 @@ Take a look at the list of supported filetypes and checkers: |syntastic-checkers
Note: This doc only deals with using syntastic. To learn how to write syntax
checker integrations, see the guide on the GitHub wiki:
- https://github.com/scrooloose/syntastic/wiki/Syntax-Checker-Guide
+ https://github.com/vim-syntastic/syntastic/wiki/Syntax-Checker-Guide
------------------------------------------------------------------------------
1.1. Quick start *syntastic-quickstart*
@@ -1196,7 +1196,7 @@ The core maintainers of syntastic are:
Find the latest version of syntastic at:
- http://github.com/scrooloose/syntastic
+ http://github.com/vim-syntastic/syntastic
==============================================================================
9. License *syntastic-license*
@@ -19,7 +19,7 @@ if has('reltime')
lockvar! g:_SYNTASTIC_START
endif
-let g:_SYNTASTIC_VERSION = '3.8.0-3'
+let g:_SYNTASTIC_VERSION = '3.8.0-4'
lockvar g:_SYNTASTIC_VERSION
" Sanity checks {{{1

0 comments on commit 7993f79

Please sign in to comment.