getmatches breaks syntastic for vim < 7.1 #250

Closed
prat0088 opened this Issue May 15, 2012 · 8 comments

Comments

Projects
None yet
8 participants
@prat0088

Commit cda7186 introduced the use of getmatches. getmatches appears to have been added in patch 7.1.040 ( http://www.cs.csubak.edu/docs/vim/version7.html ). At work, I only have access to vim 7.0. It would be great if syntastic had 7.0 support.

@greydet

This comment has been minimized.

Show comment
Hide comment
@greydet

greydet Aug 20, 2012

I am facing the same issue.
Is it possible to add a workaround or at least to check the vim version for compatibility when loading the syntastic plug-in?

greydet commented Aug 20, 2012

I am facing the same issue.
Is it possible to add a workaround or at least to check the vim version for compatibility when loading the syntastic plug-in?

@neilsh

This comment has been minimized.

Show comment
Hide comment
@neilsh

neilsh Aug 25, 2012

Same here.

neilsh commented Aug 25, 2012

Same here.

@zonca

This comment has been minimized.

Show comment
Hide comment
@zonca

zonca Sep 22, 2012

yes, got the same problem

zonca commented Sep 22, 2012

yes, got the same problem

@erikdaniel

This comment has been minimized.

Show comment
Hide comment

Same here.

rbrown added a commit to rbrown/syntastic that referenced this issue Sep 27, 2012

@rbrown

This comment has been minimized.

Show comment
Hide comment
@rbrown

rbrown Sep 27, 2012

Contributor

The patch above fixes this but shouldn't really be necessary, as putting let g:syntastic_enable_highlighting = 0 in .vimrc should stop getmatches from being called

Contributor

rbrown commented Sep 27, 2012

The patch above fixes this but shouldn't really be necessary, as putting let g:syntastic_enable_highlighting = 0 in .vimrc should stop getmatches from being called

@dbarnett

This comment has been minimized.

Show comment
Hide comment
@dbarnett

dbarnett Nov 16, 2012

Contributor

I think the logic on this check was wrong:

" highlighting requires getmatches introduced in 7.1.040
if g:syntastic_enable_highlighting == 1 &&
            \ (v:version < 701 || v:version == 701 && has('patch040'))
    let g:syntastic_enable_highlighting = 1
endif

For starters, it should be let g:syntastic_enable_highlighting = 0 or it will only every change it from 1 to 1. Also, the has('patch040') check is backwards now. I think the correct logic is

" highlighting requires getmatches introduced in 7.1.040
if g:syntastic_enable_highlighting == 1 &&
            \ (v:version < 701 || v:version == 701 && !has('patch040'))
    let g:syntastic_enable_highlighting = 0
endif
Contributor

dbarnett commented Nov 16, 2012

I think the logic on this check was wrong:

" highlighting requires getmatches introduced in 7.1.040
if g:syntastic_enable_highlighting == 1 &&
            \ (v:version < 701 || v:version == 701 && has('patch040'))
    let g:syntastic_enable_highlighting = 1
endif

For starters, it should be let g:syntastic_enable_highlighting = 0 or it will only every change it from 1 to 1. Also, the has('patch040') check is backwards now. I think the correct logic is

" highlighting requires getmatches introduced in 7.1.040
if g:syntastic_enable_highlighting == 1 &&
            \ (v:version < 701 || v:version == 701 && !has('patch040'))
    let g:syntastic_enable_highlighting = 0
endif
@scrooloose

This comment has been minimized.

Show comment
Hide comment
@scrooloose

scrooloose Nov 17, 2012

Collaborator

Yeah, cant believe I didnt spot that. Just pushed a fix - can you confirm that it works as expected?

Collaborator

scrooloose commented Nov 17, 2012

Yeah, cant believe I didnt spot that. Just pushed a fix - can you confirm that it works as expected?

@dbarnett

This comment has been minimized.

Show comment
Hide comment
@dbarnett

dbarnett Nov 19, 2012

Contributor

Yep, I can confirm 36db8f4 fixes the behavior for me. Thanks!

Contributor

dbarnett commented Nov 19, 2012

Yep, I can confirm 36db8f4 fixes the behavior for me. Thanks!

@patrickdepinguin patrickdepinguin referenced this issue in unblevable/quick-scope Oct 8, 2015

Closed

Requires vim >= 7.1.040 #22

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment