Permalink
Browse files

patch 8.0.0729: the help for the terminal configure option is wrong

Problem:    The help for the terminal configure option is wrong.
Solution:   Change "Disable" to "Enable". (E Kawashima, closes #1849)
            Improve alignment.
  • Loading branch information...
brammool committed Jul 18, 2017
1 parent 96ca27a commit 8008b6318dbd68b2c2c8cf08280768489a8f0114
Showing with 18 additions and 16 deletions.
  1. +8 −8 src/auto/configure
  2. +8 −8 src/configure.ac
  3. +2 −0 src/version.c
View
@@ -1483,23 +1483,23 @@ Optional Features:
--disable-selinux Do not check for SELinux support.
--disable-xsmp Disable XSMP session management
--disable-xsmp-interact Disable XSMP interaction
--enable-luainterp=OPTS Include Lua interpreter. default=no OPTS=no/yes/dynamic
--enable-mzschemeinterp Include MzScheme interpreter.
--enable-luainterp=OPTS Include Lua interpreter. default=no OPTS=no/yes/dynamic
--enable-mzschemeinterp Include MzScheme interpreter.
--enable-perlinterp=OPTS Include Perl interpreter. default=no OPTS=no/yes/dynamic
--enable-pythoninterp=OPTS Include Python interpreter. default=no OPTS=no/yes/dynamic
--enable-python3interp=OPTS Include Python3 interpreter. default=no OPTS=no/yes/dynamic
--enable-python3interp=OPTS Include Python3 interpreter. default=no OPTS=no/yes/dynamic
--enable-tclinterp=OPTS Include Tcl interpreter. default=no OPTS=no/yes/dynamic
--enable-rubyinterp=OPTS Include Ruby interpreter. default=no OPTS=no/yes/dynamic
--enable-cscope Include cscope interface.
--enable-workshop Include Sun Visual Workshop support.
--disable-netbeans Disable NetBeans integration support.
--disable-channel Disable process communication support.
--enable-terminal Disable terminal emulation support.
--disable-channel Disable process communication support.
--enable-terminal Enable terminal emulation support.
--enable-multibyte Include multibyte editing support.
--enable-hangulinput Include Hangul input support.
--enable-xim Include XIM input support.
--enable-fontset Include X fontset output support.
--enable-gui=OPTS X11 GUI default=auto OPTS=auto/no/gtk2/gnome2/gtk3/motif/athena/neXtaw/photon/carbon
--enable-gui=OPTS X11 GUI. default=auto OPTS=auto/no/gtk2/gnome2/gtk3/motif/athena/neXtaw/photon/carbon
--enable-gtk2-check If auto-select GUI, check for GTK+ 2 default=yes
--enable-gnome-check If GTK GUI, check for GNOME default=no
--enable-gtk3-check If auto-select GUI, check for GTK+ 3 default=yes
@@ -1513,7 +1513,7 @@ Optional Features:
--disable-largefile omit support for large files
--disable-acl Don't check for ACL support.
--disable-gpm Don't use gpm (Linux mouse daemon).
--disable-sysmouse Don't use sysmouse (mouse in *BSD console).
--disable-sysmouse Don't use sysmouse (mouse in *BSD console).
--disable-nls Don't support NLS (gettext()).
Optional Packages:
@@ -1541,7 +1541,7 @@ Optional Packages:
--with-gnome-includes=DIR Specify location of GNOME headers
--with-gnome-libs=DIR Specify location of GNOME libs
--with-gnome Specify prefix for GNOME files
--with-motif-lib=STRING Library for Motif
--with-motif-lib=STRING Library for Motif
--with-tlib=library terminal library to be used
Some influential environment variables:
View
@@ -492,7 +492,7 @@ fi
dnl Check for Lua feature.
AC_MSG_CHECKING(--enable-luainterp argument)
AC_ARG_ENABLE(luainterp,
[ --enable-luainterp[=OPTS] Include Lua interpreter. [default=no] [OPTS=no/yes/dynamic]], ,
[ --enable-luainterp[=OPTS] Include Lua interpreter. [default=no] [OPTS=no/yes/dynamic]], ,
[enable_luainterp="no"])
AC_MSG_RESULT($enable_luainterp)
@@ -690,7 +690,7 @@ fi
dnl Check for MzScheme feature.
AC_MSG_CHECKING(--enable-mzschemeinterp argument)
AC_ARG_ENABLE(mzschemeinterp,
[ --enable-mzschemeinterp Include MzScheme interpreter.], ,
[ --enable-mzschemeinterp Include MzScheme interpreter.], ,
[enable_mzschemeinterp="no"])
AC_MSG_RESULT($enable_mzschemeinterp)
@@ -1332,7 +1332,7 @@ AC_SUBST(PYTHON_OBJ)
AC_MSG_CHECKING(--enable-python3interp argument)
AC_ARG_ENABLE(python3interp,
[ --enable-python3interp[=OPTS] Include Python3 interpreter. [default=no] [OPTS=no/yes/dynamic]], ,
[ --enable-python3interp[=OPTS] Include Python3 interpreter. [default=no] [OPTS=no/yes/dynamic]], ,
[enable_python3interp="no"])
AC_MSG_RESULT($enable_python3interp)
if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic"; then
@@ -1963,7 +1963,7 @@ fi
AC_MSG_CHECKING(--disable-channel argument)
AC_ARG_ENABLE(channel,
[ --disable-channel Disable process communication support.],
[ --disable-channel Disable process communication support.],
, [enable_channel="yes"])
if test "$enable_channel" = "yes"; then
if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
@@ -2030,7 +2030,7 @@ fi
AC_MSG_CHECKING(--enable-terminal argument)
AC_ARG_ENABLE(terminal,
[ --enable-terminal Disable terminal emulation support.],
[ --enable-terminal Enable terminal emulation support.],
[enable_terminal="yes"], )
if test "$enable_terminal" = "yes"; then
if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
@@ -2214,7 +2214,7 @@ test "x$with_x" = xno -a "x$MACOSX" != "xyes" -a "x$QNX" != "xyes" && enable_gui
AC_MSG_CHECKING(--enable-gui argument)
AC_ARG_ENABLE(gui,
[ --enable-gui[=OPTS] X11 GUI [default=auto] [OPTS=auto/no/gtk2/gnome2/gtk3/motif/athena/neXtaw/photon/carbon]], , enable_gui="auto")
[ --enable-gui[=OPTS] X11 GUI. [default=auto] [OPTS=auto/no/gtk2/gnome2/gtk3/motif/athena/neXtaw/photon/carbon]], , enable_gui="auto")
dnl Canonicalize the --enable-gui= argument so that it can be easily compared.
dnl Do not use character classes for portability with old tools.
@@ -2782,7 +2782,7 @@ dnl files, to avoid a mixup if several versions are present
if test -z "$SKIP_MOTIF"; then
AC_MSG_CHECKING(--with-motif-lib argument)
AC_ARG_WITH(motif-lib,
[ --with-motif-lib=STRING Library for Motif ],
[ --with-motif-lib=STRING Library for Motif ],
[ MOTIF_LIBNAME="${withval}" ] )
if test -n "$MOTIF_LIBNAME"; then
@@ -3874,7 +3874,7 @@ fi
AC_MSG_CHECKING(--disable-sysmouse argument)
AC_ARG_ENABLE(sysmouse,
[ --disable-sysmouse Don't use sysmouse (mouse in *BSD console).], ,
[ --disable-sysmouse Don't use sysmouse (mouse in *BSD console).], ,
[enable_sysmouse="yes"])
if test "$enable_sysmouse" = "yes"; then
View
@@ -769,6 +769,8 @@ static char *(features[]) =
static int included_patches[] =
{ /* Add new patch number below this line */
/**/
729,
/**/
728,
/**/

0 comments on commit 8008b63

Please sign in to comment.