Permalink
Browse files

patch 8.0.1155: Ruby command triggers a warning

Problem:    Ruby command triggers a warning when RUBYOPT is set to "-w".
Solution:   use "-e_=0" instead of "-e0". (Masataka Pocke Kuwabara, closes
            #2143)
  • Loading branch information...
brammool committed Sep 26, 2017
1 parent 1b38344 commit d1bc96ce2466ac1b4af4a2c36de455a1df318d1d
Showing with 3 additions and 1 deletion.
  1. +1 −1 src/if_ruby.c
  2. +2 −0 src/version.c
View
@@ -882,7 +882,7 @@ static int ensure_ruby_initialized(void)
#ifdef RUBY19_OR_LATER
{
int dummy_argc = 2;
char *dummy_argv[] = {"vim-ruby", "-e0"};
char *dummy_argv[] = {"vim-ruby", "-e_=0"};
ruby_options(dummy_argc, dummy_argv);
}
ruby_script("vim-ruby");
View
@@ -761,6 +761,8 @@ static char *(features[]) =
static int included_patches[] =
{ /* Add new patch number below this line */
/**/
1155,
/**/
1154,
/**/

0 comments on commit d1bc96c

Please sign in to comment.