Permalink
Browse files

cleaning up gems so I remember what is necessary to run all of this

  • Loading branch information...
1 parent 2d8258b commit d36a50a1574e45c8ebdee17832244c7e710d13a2 @tomcz tomcz committed Sep 27, 2011
Showing with 24 additions and 19 deletions.
  1. +7 −3 Gemfile
  2. +12 −14 Gemfile.lock
  3. +2 −2 config/database.yml
  4. +1 −0 config/environment.rb
  5. +2 −0 rake.sh
View
10 Gemfile
@@ -1,15 +1,19 @@
source 'http://rubygems.org'
gem 'rails', '2.3.8'
-gem 'ruby-mysql', '2.9.3'
gem 'uuidtools', '2.1.1'
gem 'haml', '3.1.3'
+gem 'sass', '3.1.7'
gem 'rdoc', '3.9.4'
+# env ARCHFLAGS="-arch x86_64" gem install mysql -- --with-mysql-config=/usr/local/mysql/bin/mysql_config
+# export DYLD_LIBRARY_PATH="/usr/local/mysql/lib:$DYLD_LIBRARY_PATH"
+gem 'mysql', '2.8.1'
+
group :development, :test do
gem 'cucumber-rails', '0.3.0'
- #gem 'database_cleaner', '0.5.0'
- #gem 'rspec', '1.3.0'
+ gem 'database_cleaner', '0.5.0'
+ gem 'rspec', '1.3.0'
gem 'test-unit', '1.2.3'
gem 'rspec-rails', '1.3.2'
gem 'webrat', '0.7.0'
View
@@ -12,21 +12,23 @@ GEM
activesupport (= 2.3.8)
activesupport (2.3.8)
builder (3.0.0)
- cucumber (1.0.6)
+ cucumber (1.1.0)
builder (>= 2.1.2)
diff-lcs (>= 1.1.2)
- gherkin (~> 2.4.18)
+ gherkin (~> 2.5.0)
json (>= 1.4.6)
term-ansicolor (>= 1.0.6)
cucumber-rails (0.3.0)
cucumber (>= 0.6.2)
+ database_cleaner (0.5.0)
diff-lcs (1.1.3)
- gherkin (2.4.21)
+ gherkin (2.5.1)
json (>= 1.4.6)
haml (3.1.3)
hoe (2.12.3)
rake (~> 0.8)
- json (1.6.0)
+ json (1.6.1)
+ mysql (2.8.1)
nokogiri (1.5.0)
rack (1.1.2)
rack-test (0.6.1)
@@ -40,18 +42,11 @@ GEM
rake (>= 0.8.3)
rake (0.9.2)
rdoc (3.9.4)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
+ rspec (1.3.0)
rspec-rails (1.3.2)
rack (>= 1.0.0)
rspec (>= 1.3.0)
- ruby-mysql (2.9.3)
+ sass (3.1.7)
term-ansicolor (1.0.6)
test-unit (1.2.3)
hoe (>= 1.5.1)
@@ -66,11 +61,14 @@ PLATFORMS
DEPENDENCIES
cucumber-rails (= 0.3.0)
+ database_cleaner (= 0.5.0)
haml (= 3.1.3)
+ mysql (= 2.8.1)
rails (= 2.3.8)
rdoc (= 3.9.4)
+ rspec (= 1.3.0)
rspec-rails (= 1.3.2)
- ruby-mysql (= 2.9.3)
+ sass (= 3.1.7)
test-unit (= 1.2.3)
uuidtools (= 2.1.1)
webrat (= 0.7.0)
View
@@ -18,7 +18,7 @@ development:
adapter: mysql
encoding: utf8
reconnect: false
- database: depot_development
+ database: depot_dev
pool: 5
username: root
password:
@@ -41,7 +41,7 @@ production:
adapter: mysql
encoding: utf8
reconnect: false
- database: depot_production
+ database: depot_prod
pool: 5
username: root
password:
View
@@ -20,6 +20,7 @@
# config.gem "sqlite3-ruby", :lib => "sqlite3"
# config.gem "aws-s3", :lib => "aws/s3"
config.gem "haml"
+ config.gem "sass"
# Only load the plugins named here, in the order given (default is alphabetical).
# :all can be used as a placeholder for all plugins not explicitly named
View
@@ -0,0 +1,2 @@
+#!/bin/bash
+bundle exec rake $@

0 comments on commit d36a50a

Please sign in to comment.