Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

Adding PyUpdater #720

Closed
wants to merge 1 commit into from
Closed

Adding PyUpdater #720

wants to merge 1 commit into from

Conversation

@JMSwag
Copy link

@JMSwag JMSwag commented Sep 10, 2016

What is this Python project?

A library that adds auto-update functionality to a PyInstaller compiled app.

What's the difference between this Python project and similar ones?

So far PyUpdater is the only library that supports PyInstaller

Anyone who agrees with this pull request could vote for it by adding a 馃憤 to it, and usually, the maintainer will merge it when votes reach 20.

Enables a PyInstaller compiled app to auto update itself with very minimal work from the developer.

PyUpdater Docs

Enables a PyInstaller compiled app to auto update itself with very minimal work from the developer.
@vinta vinta force-pushed the master branch 2 times, most recently from 23abd09 to 40cd98b Jun 6, 2019
@stale
Copy link

@stale stale bot commented Oct 30, 2019

This issue has been automatically marked as stale because it has not had recent activity. It will be closed if no further activity occurs. Thank you for your contributions.

@stale stale bot added the stale label Oct 30, 2019
@JMSwag
Copy link
Author

@JMSwag JMSwag commented Nov 3, 2019

@vinta Hey, 20 votes here ;)

@stale stale bot removed the stale label Nov 3, 2019
@stale stale bot added the stale label Dec 4, 2019
@stale stale bot closed this Dec 4, 2019
@TheTechRobo
Copy link

@TheTechRobo TheTechRobo commented Apr 21, 2020

@vinta PyUpdater is a great project, it should be added..
Ten upvotes from here!

@NicklasTegner
Copy link

@NicklasTegner NicklasTegner commented Oct 9, 2020

+1 here

@elgizabbasov
Copy link

@elgizabbasov elgizabbasov commented Jun 1, 2021

Hello I have an issue with downloading PyUpdater. I used pip install PyUpdater on my VSCode terminal however I keep getting this error:
image
I am using python 3.9.1 version and I can not find any solutions to this problem. It seems like its having trouble with downloading bsdiff4 lib however I tried pip install bsdiff4 as well and ended up with the same output as in the screenshot. Any help would be appreciated

@NicklasTegner
Copy link

@NicklasTegner NicklasTegner commented Jun 3, 2021

hi @elgizabbasov

I think you will have more luck, opening an issue on the PyUpdater repository :)

@elgizabbasov
Copy link

@elgizabbasov elgizabbasov commented Jun 3, 2021

hi @elgizabbasov

I think you will have more luck, opening an issue on the PyUpdater repository :)

I have put this issue there however it got closed because it is a "general software question" and I have to know how to fix it if I am a developer. There is probably only 1000 people using pyupdater, thus very limited resources on the net and I have tried literally everything available. I also posted an issue on the bsdiff4 repo since that's where I am having issues but they have not replied to their issues in more than 2 years now. I really do not know what to do

@JMSwag
Copy link
Author

@JMSwag JMSwag commented Jun 4, 2021

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants