Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rendering a Viro3DObject crashes on Adreno 320 #465

Closed
slycoder opened this issue Nov 13, 2018 · 4 comments

Comments

Projects
None yet
3 participants
@slycoder
Copy link

commented Nov 13, 2018

Environment

  1. Development OS: Mac
  2. Device OS & Version: Android 6.0.
  3. Version: ViroReact 2.11.0, React Native 0.57.4.
  4. Device(s): MotoX (XT1053) /w Adreno 320 gpu.

Description

The following crash occurs whenever a Viro3DObject is mounted:
https://gist.github.com/slycoder/07fad4b3b805e97edfcbbf79804c484d

This only occurs on certain devices. The Adreno 3xx is known to have lots of issues that require workarounds, e.g.,

godotengine/godot#14902

@slycoder slycoder changed the title Rendering a Viro3DObject crash on Adreno 320 Rendering a Viro3DObject crashes on Adreno 320 Nov 13, 2018

@radvani

This comment has been minimized.

Copy link
Contributor

commented Nov 13, 2018

Hi @slycoder, yes this appears to be a shader compilation failure on Adreno 320. We actually use an entirely separate group of shaders for Adreno 320 because of all of its compatibility problems; this crash must be related to one of those. Thanks, we'll keep this bug updated with information.

@slycoder

This comment has been minimized.

Copy link
Author

commented Nov 13, 2018

Yeah, given how crazily bad the Adreno 3xx is, it almost seems like false advertising for them to call it openGL 3.0 compatible =).

@radvani

This comment has been minimized.

Copy link
Contributor

commented Nov 13, 2018

We just fixed this issue and it will be available in our release later this week. (Keep in mind though that for Adreno 320 we run in a stripped down 'compatibility mode' where most lighting effects are disabled). Thanks!

@manbod

This comment has been minimized.

Copy link
Collaborator

commented Nov 19, 2018

Hi @slycoder ,
We just released ViroReact version 2.12.0, that resolves this issue. Check it at -> https://docs.viromedia.com/docs/releases. Closing this issue. Let us know if you still see the same.

@manbod manbod closed this Nov 19, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.