New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compilation error #4

Open
igitur opened this Issue Jan 12, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@igitur
Copy link

igitur commented Jan 12, 2019

I get this when I try to install flow using Rust version rustc 1.31.1 (b6c32da9b 2018-12-18)

   Compiling flow v0.3.5
error[E0599]: no method named `contains` found for type `std::option::Option<std::string::String>` in the current scope
  --> /home/igitur/.cargo/registry/src/github.com-1ecc6299db9ec823/flow-0.3.5/src/ui/input.rs:93:17
   |
93 |         if name.contains('^') {
   |                 ^^^^^^^^

error[E0599]: no method named `chars` found for type `std::option::Option<std::string::String>` in the current scope
  --> /home/igitur/.cargo/registry/src/github.com-1ecc6299db9ec823/flow-0.3.5/src/ui/input.rs:95:40
   |
95 |             let value = Key::Char(name.chars().last().unwrap());
   |                                        ^^^^^

error: aborting due to 2 previous errors

For more information about this error, try `rustc --explain E0599`.
error: failed to compile `flow v0.3.5`, intermediate artifacts can be found at `/tmp/cargo-installDHXIrY`

Caused by:
  Could not compile `flow`.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment