Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

release 4.0.5

  • Loading branch information...
commit 055bd80b29b964c50a1e3e721b811362c199682e 1 parent b193606
Gabriel Gilder authored
11 History.rdoc
Source Rendered
... ... @@ -1,3 +1,14 @@
  1 +4.0.5 / 2011-08-09
  2 +==================
  3 +
  4 + * Updated documentation to fix inaccuracies and unclear information.
  5 + * Improved rake tasks for gem development.
  6 + * Added say_ok, say_warning and say_error methods to print messages in green, yellow or red. (thanks to Simon Courtois)
  7 + * Fixed; Allow global options to be passed in any order, even mixed with command options. (thanks to Rich Grundy)
  8 + * Fixed; Global options can be passed before or after the command, they can even be mixed with command options. Closes #8. (thanks to Rich Grundy)
  9 + * Fixed; Platform test should now correctly identify JRuby. (thanks to Justin Lynn)
  10 + * Fixed; Add to_s to exceptions as option parser no longer does implicit conversion. (thanks to Justin Lynn)
  11 +
1 12 4.0.4 / 2011-04-04
2 13 ==================
3 14
1  Manifest
@@ -4,6 +4,7 @@ Manifest
4 4 README.rdoc
5 5 Rakefile
6 6 bin/commander
  7 +commander.gemspec
7 8 lib/commander.rb
8 9 lib/commander/blank.rb
9 10 lib/commander/command.rb
14 commander.gemspec
@@ -2,16 +2,16 @@
2 2
3 3 Gem::Specification.new do |s|
4 4 s.name = %q{commander}
5   - s.version = "4.0.4"
  5 + s.version = "4.0.5"
6 6
7 7 s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
8 8 s.authors = [%q{TJ Holowaychuk}, %q{Gabriel Gilder}]
9   - s.date = %q{2011-08-02}
  9 + s.date = %q{2011-08-09}
10 10 s.description = %q{The complete solution for Ruby command-line executables}
11 11 s.email = %q{ggilder@tractionco.com}
12 12 s.executables = [%q{commander}]
13   - s.extra_rdoc_files = [%q{README.rdoc}, %q{bin/commander}, %q{lib/commander.rb}, %q{lib/commander/blank.rb}, %q{lib/commander/command.rb}, %q{lib/commander/core_ext.rb}, %q{lib/commander/core_ext/array.rb}, %q{lib/commander/core_ext/object.rb}, %q{lib/commander/delegates.rb}, %q{lib/commander/help_formatters.rb}, %q{lib/commander/help_formatters/base.rb}, %q{lib/commander/help_formatters/terminal.rb}, %q{lib/commander/help_formatters/terminal/command_help.erb}, %q{lib/commander/help_formatters/terminal/help.erb}, %q{lib/commander/help_formatters/terminal_compact.rb}, %q{lib/commander/help_formatters/terminal_compact/command_help.erb}, %q{lib/commander/help_formatters/terminal_compact/help.erb}, %q{lib/commander/import.rb}, %q{lib/commander/platform.rb}, %q{lib/commander/runner.rb}, %q{lib/commander/user_interaction.rb}, %q{lib/commander/version.rb}, %q{tasks/docs.rake}, %q{tasks/gemspec.rake}]
14   - s.files = [%q{History.rdoc}, %q{Manifest}, %q{README.rdoc}, %q{Rakefile}, %q{bin/commander}, %q{commander.gemspec}, %q{lib/commander.rb}, %q{lib/commander/blank.rb}, %q{lib/commander/command.rb}, %q{lib/commander/core_ext.rb}, %q{lib/commander/core_ext/array.rb}, %q{lib/commander/core_ext/object.rb}, %q{lib/commander/delegates.rb}, %q{lib/commander/help_formatters.rb}, %q{lib/commander/help_formatters/base.rb}, %q{lib/commander/help_formatters/terminal.rb}, %q{lib/commander/help_formatters/terminal/command_help.erb}, %q{lib/commander/help_formatters/terminal/help.erb}, %q{lib/commander/help_formatters/terminal_compact.rb}, %q{lib/commander/help_formatters/terminal_compact/command_help.erb}, %q{lib/commander/help_formatters/terminal_compact/help.erb}, %q{lib/commander/import.rb}, %q{lib/commander/platform.rb}, %q{lib/commander/runner.rb}, %q{lib/commander/user_interaction.rb}, %q{lib/commander/version.rb}, %q{spec/command_spec.rb}, %q{spec/core_ext/array_spec.rb}, %q{spec/core_ext/object_spec.rb}, %q{spec/help_formatters/terminal_spec.rb}, %q{spec/runner_spec.rb}, %q{spec/spec.opts}, %q{spec/spec_helper.rb}, %q{spec/ui_spec.rb}, %q{tasks/docs.rake}, %q{tasks/gemspec.rake}]
  13 + s.extra_rdoc_files = [%q{README.rdoc}, %q{bin/commander}, %q{lib/commander.rb}, %q{lib/commander/blank.rb}, %q{lib/commander/command.rb}, %q{lib/commander/core_ext.rb}, %q{lib/commander/core_ext/array.rb}, %q{lib/commander/core_ext/object.rb}, %q{lib/commander/delegates.rb}, %q{lib/commander/help_formatters.rb}, %q{lib/commander/help_formatters/base.rb}, %q{lib/commander/help_formatters/terminal.rb}, %q{lib/commander/help_formatters/terminal/command_help.erb}, %q{lib/commander/help_formatters/terminal/help.erb}, %q{lib/commander/help_formatters/terminal_compact.rb}, %q{lib/commander/help_formatters/terminal_compact/command_help.erb}, %q{lib/commander/help_formatters/terminal_compact/help.erb}, %q{lib/commander/import.rb}, %q{lib/commander/platform.rb}, %q{lib/commander/runner.rb}, %q{lib/commander/user_interaction.rb}, %q{lib/commander/version.rb}, %q{tasks/dev_setup.rake}, %q{tasks/docs.rake}, %q{tasks/gemspec.rake}]
  14 + s.files = [%q{DEVELOPMENT}, %q{History.rdoc}, %q{Manifest}, %q{README.rdoc}, %q{Rakefile}, %q{bin/commander}, %q{commander.gemspec}, %q{lib/commander.rb}, %q{lib/commander/blank.rb}, %q{lib/commander/command.rb}, %q{lib/commander/core_ext.rb}, %q{lib/commander/core_ext/array.rb}, %q{lib/commander/core_ext/object.rb}, %q{lib/commander/delegates.rb}, %q{lib/commander/help_formatters.rb}, %q{lib/commander/help_formatters/base.rb}, %q{lib/commander/help_formatters/terminal.rb}, %q{lib/commander/help_formatters/terminal/command_help.erb}, %q{lib/commander/help_formatters/terminal/help.erb}, %q{lib/commander/help_formatters/terminal_compact.rb}, %q{lib/commander/help_formatters/terminal_compact/command_help.erb}, %q{lib/commander/help_formatters/terminal_compact/help.erb}, %q{lib/commander/import.rb}, %q{lib/commander/platform.rb}, %q{lib/commander/runner.rb}, %q{lib/commander/user_interaction.rb}, %q{lib/commander/version.rb}, %q{spec/command_spec.rb}, %q{spec/core_ext/array_spec.rb}, %q{spec/core_ext/object_spec.rb}, %q{spec/help_formatters/terminal_spec.rb}, %q{spec/runner_spec.rb}, %q{spec/spec.opts}, %q{spec/spec_helper.rb}, %q{spec/ui_spec.rb}, %q{tasks/dev_setup.rake}, %q{tasks/docs.rake}, %q{tasks/gemspec.rake}]
15 15 s.homepage = %q{http://visionmedia.github.com/commander}
16 16 s.rdoc_options = [%q{--line-numbers}, %q{--inline-source}, %q{--title}, %q{Commander}, %q{--main}, %q{README.rdoc}]
17 17 s.require_paths = [%q{lib}]
@@ -26,17 +26,17 @@ Gem::Specification.new do |s|
26 26 s.add_runtime_dependency(%q<highline>, [">= 1.5.0"])
27 27 s.add_development_dependency(%q<echoe>, [">= 4.0.0"])
28 28 s.add_development_dependency(%q<sdoc>, [">= 0.2.20"])
29   - s.add_development_dependency(%q<rspec>, ["< 2"])
  29 + s.add_development_dependency(%q<rspec>, ["~> 1.3"])
30 30 else
31 31 s.add_dependency(%q<highline>, [">= 1.5.0"])
32 32 s.add_dependency(%q<echoe>, [">= 4.0.0"])
33 33 s.add_dependency(%q<sdoc>, [">= 0.2.20"])
34   - s.add_dependency(%q<rspec>, ["< 2"])
  34 + s.add_dependency(%q<rspec>, ["~> 1.3"])
35 35 end
36 36 else
37 37 s.add_dependency(%q<highline>, [">= 1.5.0"])
38 38 s.add_dependency(%q<echoe>, [">= 4.0.0"])
39 39 s.add_dependency(%q<sdoc>, [">= 0.2.20"])
40   - s.add_dependency(%q<rspec>, ["< 2"])
  40 + s.add_dependency(%q<rspec>, ["~> 1.3"])
41 41 end
42 42 end
2  lib/commander/version.rb
... ... @@ -1,4 +1,4 @@
1 1
2 2 module Commander
3   - VERSION = '4.0.4'
  3 + VERSION = '4.0.5'
4 4 end

0 comments on commit 055bd80

Please sign in to comment.
Something went wrong with that request. Please try again.