Skip to content
This repository

not compatible with latest node npm #30

Open
Gozala opened this Issue · 2 comments

3 participants

Irakli Gozalishvili ippa Forbes Lindesay
Irakli Gozalishvili

dox is broken on lates version of npm node due to module loader changes.

ippa
ippa commented

I think I got hit with the same issue:

$ dox --title Rect src/rect.js

node.js:198
throw e; // process.nextTick error, or 'error' event on first tick
^
Error: require.paths is removed. Use node_modules folders, or the NODE_PATH environment variable instead.
at Function. (module.js:360:11)
at Object. (/usr/local/lib/node_modules/dox/lib/dox/index.js:12:8)
at Module._compile (module.js:416:26)
at Object..js (module.js:422:10)
at Module.load (module.js:335:31)
at Function._load (module.js:294:12)
at Module.require (module.js:341:17)
at require (module.js:352:17)
at Object. (/usr/local/lib/node_modules/dox/bin/dox:9:1)
at Module._compile (module.js:416:26)

Forbes Lindesay

Needs closing

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.