Skip to content

Somthing between verion 0.9.0 and 0.9.1 has broken -I feature #138

Open
aomega opened this Issue Oct 14, 2011 · 5 comments

5 participants

@aomega
aomega commented Oct 14, 2011

Hi,

I noticed today that our unit tests have started failing, even though we have not changed our code in the interim. I tracked it down to a version change between 0.9.0 and 0.9.1 of expresso. We use the -I option to name the lib directory for the tests. This works in 0.9.0. In 0.9.1 we get the error:

expresso -I lib

uncaught undefined: Error: Cannot find module 'purger'
at Function._resolveFilename (module.js:317:11)
at Function._load (module.js:262:25)
at require (module.js:346:19)
at Object. (/home/jroberts/workspace/logger/test/test-purger.js:11:14)
at Module._compile (module.js:402:26)
at Object..js (module.js:408:10)
at Module.load (module.js:334:31)
at Function._load (module.js:293:12)
at require (module.js:346:19)
at runFile (/home/jroberts/workspace/logger/node_modules/expresso/bin/expresso:810:15)

@tj
Sloth member
tj commented Oct 14, 2011

wont work with node 0.5.x because require.paths is deprecated

@aomega
aomega commented Oct 14, 2011

I don't have node 0.5.x. This is on 0.4.11. Are you saying the -I feature has been removed?

@barncow
barncow commented Oct 14, 2011

I can confirm this issue. I'm running Node 0.4.12 on Ubuntu 10.04. On version 0.9.0 the -I switch works but not in 0.9.1 or 0.9.2.

@alno
alno commented Oct 17, 2011

This option was removed to provide 0.5.x compability - 6961879

But this option is used in many projects. Are there any replacements for it?

@zxcabs
zxcabs commented Nov 15, 2011

u can use NODE_PATH

for example:

expresso -I lib test/*

equal

NODE_PATH=lib expresso test/*
@gavinuhma gavinuhma referenced this issue in socketio/socket.io-client Jan 27, 2012
Closed

make test errors in 0.8.7 on node 0.4 and 0.6 #376

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.