Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Making all in js fails #169

Open
ScOut3R opened this Issue · 2 comments

2 participants

@ScOut3R

Hello,

i'm trying to install expresso on FreeBSD 8.1-RELEASE for Sparkleshare Dashboard, but i'm receiving a build error:

gcc -std=gnu99 -Ijs -Ijs/obj -DXP_UNIX -g -O2   -o generate-resources generate-resources.o  
./generate-resources jscoverage-help.txt jscoverage-server-help.txt  jscoverage.jsm jscoverage.manifest jscoverage.xul jscoverage-overlay.js  jscoverage.html  jscoverage.css jscoverage-ie.css jscoverage-highlight.css  jscoverage.js report.js  jscoverage-throbber.gif > resources.c
make  all-recursive
Making all in js
make: don't know how to make all. Stop
*** Error code 1

Stop in /var/www/sparkleshare/node_modules/expresso/deps/jscoverage.
*** Error code 1

Stop in /var/www/sparkleshare/node_modules/expresso/deps/jscoverage.
*** Error code 1

Stop in /var/www/sparkleshare/node_modules/expresso.

npm ERR! expresso@0.9.2 preinstall: `make deps/jscoverage/node-jscoverage`
npm ERR! `sh "-c" "make deps/jscoverage/node-jscoverage"` failed with 1
npm ERR! 
npm ERR! Failed at the expresso@0.9.2 preinstall script.
npm ERR! This is most likely a problem with the expresso package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     make deps/jscoverage/node-jscoverage
npm ERR! You can get their info via:
npm ERR!     npm owner ls expresso
npm ERR! There is likely additional logging output above.
npm ERR! 
npm ERR! System FreeBSD 8.1-RELEASE-p1
npm ERR! command "node" "/usr/local/bin/npm" "install" "expresso"
npm ERR! cwd /var/www/sparkleshare
npm ERR! node -v v0.6.18
npm ERR! npm -v 1.1.21
npm ERR! code ELIFECYCLE
npm ERR! message expresso@0.9.2 preinstall: `make deps/jscoverage/node-jscoverage`
npm ERR! message `sh "-c" "make deps/jscoverage/node-jscoverage"` failed with 1
npm ERR! errno {}
npm ERR!

I'm totally new to nodejs so i'm not sure wether this problem is caused by something i have with my system or if i'm missing something. If you need more info the track down this issue please let me know so i can provide it for you.

Best regards,
Mate

@bartdesign

Hi, i also have this problem on ubuntu lucid.

@bartdesign

Ok, So I guess I've had a different error. Becuase my fix was to reinstall g++.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.