@kornelski kornelski released this Nov 23, 2016 · 339 commits to master since this release

Assets 2

There are no big breaking changes and the upgrade should be smooth.

We no longer support Node 0.x. If you're still using Internet Explorer 6 Node 0.x, please please upgrade ASAP, as the old Node isn't even getting security patches any more.

  • Dropped support for Node 0.10 and 0.12.
  • Dropped support for componentjs (Damien Caselli)
  • Multiple .send() calls mixing Buffer/Blob and JSON data are not possible and will now throw instead of messing up the data.
  • Improved .send() data object type check (Fernando Mendes)
  • Added pfx TLS option with new pfx() method. (Reid Burke)
  • Added common prototype for Node and browser versions (Andreas Helmberger)
  • Added http+unix: schema to support Unix sockets (Yuki KAN)
  • Added full attach options parameter in the Node version (Lapo Luchini)
  • Internally changed .on to .once to prevent possible memory leaks (Matt Blair)
  • Made all errors reported as an event (Kornel Lesiński)
  • set xhr.response instead of xhr.responseText to err.rawResponse (Pavel Ayusheev)