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Our simulation capabilities support experimental discovery

The National Ignition Facility (NIF) A Visualization of a NIF Experiment
https://www.flickr.com/photos/IInl/2842663693/in/album- https://www.flickr.com/photos/IInl/2843501990/in/album-
72157607099824019/ 72157607099824019/
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What is The National Ignition Facility (NIF)?

= The NIF is the world’s largest and highest-energy laser, and a
High Energy Density Physics (HEDP) experimental platform.

= NIF is capable of creating temperatures (in excess of 3 million
degrees kelvin) and pressures (hundreds of billions of earth
atmospheres) similar to those that exist only in the cores of
stars and giant planets and inside nuclear weapons.

= For Inertial Confinement Fusion (ICF) experiments, it focuses
192 giant laser beams on what is called a hohlraum, which is a
small gold cylinder that holds a BB-sized target capsule filled
with hydrogen fuel.

= After decades of work, we were finally able to achieve fusion at
NIF: an ICF experiment generated more energy (3.15 ’ | |
megajoules) from the fusion reaction than the laser energy (2.05 hitos: /. Inl.gov/inews/national-ignition-facility-
MJ) delivered to the hohlraum. achieves-fusion-ignition
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Simulations and Experiments work hand in hand to enable High
Energy Density Physics Research

= Achieving fusion required a great deal of
precision for every piece of the puzzle.

= We use simulation codes and visualization
tools to help us design and iterate on our
experiments.

= We would not have achieved ignition
without interplay between computer
simulations and experiments; neither one
can do the job on its own.

Hydra is one of the simulation codes that

LLNL uses to simulate ICF experiments.
https://weci.lInl.gov/stockpile-science/high-

performance-computing/proprietary-software
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Experimental Diagnostics

= The NIF lasers heat the hohlraum to millions of degrees
Fahrenheit, causing the gold wall to emit x rays.

= We use diagnostics during experiments to detect these x
rays.

= The data they capture is used to calculate the radiation
spectrum and infer the temperature of the radiation field
within the hohlraum. This information is directly compared
to hohlraum simulations to determine if the hohlraum and
laser pulse are performing as expected.

= DANTE and GXD are two of many types of diagnostics used.

= We want to simulate these diagnostics so we can have an

analog to real world experimental diagnostics. DANTE Diagnostic
https://www.flickr.com/photos/lInl/3775084967
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A Tale of Two Workflows

Simulation Workflow

¢ N ([ ) 4 D c D s D )
Simulation Y
‘ Physics Mesh Outputs Vislt X Ray Conduit Detector Simulated
> Simglation (with Absorbtivity » Image Query »Blueprint Output »  Simulation » Diagnostic
‘ and Emissivity (Ray Trace) Files (Dante, GXD, etc.) Result
fields)
(S Y. AN / N Y AN / e S
. < Y. < v
Experimental \_ < y, < / )
Design ~
(¢ N N O 2
- Experiment DT > Eé?ae rlr:gizrzal
P " | (Dante, GXD, etc.) - Rgesult

Experimental Workflow
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Gated Xray Detector (GXD) Example

N\ GXD-090-315 shape and temporal evolution is similar

;‘;E for N091021-002 NI w Comparisons of simulated x-ray data to
S ONIF experiments

~
Simulated Authors: Steve Langer, Richard Town,
»  Diagnostic George Kyrala, Marilyn Schneider,
Result Jose Milovich, Nathan Meezan, Oggie
Jones, and Scott Sepke
/
~ Presented at the Anomalous
Absorption Conference
Experimental
> Di t
e 13-18 June 2010

/ time ->

duration ~ 200 ps
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A Tale of Two Workflows: Our Focus for This Talk

Simulation Workflow

[ N ([ (o 4 ) / ) ) )
Simulation Y
‘ Physics Mesh Outputs Vislt X Ray Conduit Detector Simulated
> Simglation » (with Absorbtivity » Image Query »Blueprint Output »  Simulation » Diagnostic
‘ J and Emissivity (Ray Trace) Files (Dante, GXD, etc.) Result
fields)
(S - Y. J AN / \\ Y J AN / e S
Experimental \_ N y, < vy, )
Design ~
(¢ N N O 2
- Experiment > DT > Eé?aeggiﬂfl
(Dante, GXD, etc.)
Result

Experimental Workflow
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What is the Vislt X Ray Image Query?

(o - n )
Simulation \\
Mesh Outputs Vislt X Ray Conduit
> (with Absorbtivity » Image Query »Blueprint Output
and Emissivity (Ray Trace) Files
fields) ;
J \ J & //
f \ \ f

= The X Ray Image Query is part of a larger workflow that helps us to simulate x ray detectors.

= The query computes the attenuation and self-emission for radiation passing through an
object.

A 4

= The input is a mesh with zone-centered opacities (absorbtivities) and emissivities. (These can

be arrays to support multiple energy groups.)

= The output is a set of images representing the result of a ray trace for each energy group.

LLNL-PRES-847902
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Problems with the X Ray Image Query Workflow

= Steve Langer (who has decades of experience as an ICF designer) has helped us identify
problems and feature ideas for the X Ray Image Query Workflow.

= Big Pain Point: X Ray Image Query creates too many files that were very difficult to manage.
For Example:
— Ray Tracing 60 energy groups would generate 120 BOV files.
— These files lack important context/metadata about the details of the raytrace setup.
— The name scheme of these files is esoteric.
— These file sets led to a lot of external data management that was easy to get wrong.

= Additionally, users had to choose between raw data or image files; it was not easy to have
both.

= To simplify things, we reorganized the X Ray Image Query to output Conduit Blueprint data.

. . ¢ ’el
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Conduit provides intuitive APIs for in-memory data description
and exchange

= Provides an intuitive API for in-memory data description Q
— Enables human-friendly hierarchical data organization CONDUII

Thwergy ]

— Can describe in-memory arrays without copying

— Provides C++, C, Python, and Fortran APlIs

= Provides common conventions for exchanging complex data o »
Hierarchical in-memory data description

— Shared conventions for passing complex data (e.g. Simulation Meshes) enable
modular interfaces across software libraries and simulation applications

= Provides easy to use 1/0 interfaces for moving and storing
data

— Enables use cases like binary checkpoint restart

Conventions for sharing in-memory mesh data

http://software.llnl.gov/conduit
http://github.com/lInl/conduit

Website and GitHub Repo

— Supports moving complex data with MPI (serialization)

l Lawrence Livermore National Laboratory N Sﬁf_@f& 12
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Why was Conduit Blueprint output a good choice for this
data?

= Each X Ray Image Query call now generates one file.

= The single output file presents the query output in multiple ways using well-described
meshes.

= There are three supported Conduit output types: HDF5, YAML, and JSON.

= |nstead of having to choose between only getting out data or only getting out an image, we
get the best of both worlds, because all the meshes provided in the output can be plotted in
Vislt and everything in the output can be digested in Python using Conduit’s Python API.

= The output also includes metadata such as...
— View parameters (view normal, focus, imaging planes, etc.)
— Query parameters (variable names, pixel extents, units, etc.)
— Other metadata (spatial extents, variable maxes and mins, etc.)

- . ( ’el
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What does the Blueprint Output look like?

state:
time: 4.8
cycle: 48

Xray view:
Xray_query:
xray data:

domain id: @

coordsets:
image coords:
type: "rectilinear”

values:
x: [@, 1, 2, ..., 399, 400]
y: [0, 1, 2, ..., 299, 300]
z: [@, 1]
labels:
x: "width"
y: "height”
Z: "energy_ group"
units:
x: "pixels”
y: "pixels”
Z: "bins"

topologies:
image topo:
coordset: "image coords”
type: "rectilinear”

(Condensed Example of YAML-style output)

A render of the output topology
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Output provides per-energy group 2D intensities and path
lengths stacked into a 3D grid

fields:

intensities:
topology: "image topo"
association: "element"
units: "intensity units”
values: [©.281004697084427, ©.281836241483688, 0.282898783683777,
strides: [1, 408, 120000 ]

path_length:
topology: "image topo”
association: "element”
units: "path length metadata"

values: [2.46405696868896, 2.45119333267212, 2.43822622299194,
strides: [1, 400, 120000]

.., 0.0, 0.0]

Y (spatial)

.., 0.9, 0.0]

(Condensed Example of YAML-style output)

A render of the output intensities field
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Output provides imaging planes and rays meshes so users can easily
visualize the simulated x ray detector setup alongside their input data

n]\
‘I

|

//I

Ray corners -> view frustum
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Output provides collapsed 2D Spatial Energy Images and
Spectra Curves

1 0.764]
6.0
] 0.

000000

000000

Spatial energy reduced mesh 1D speéfi:é curve

(All energy groups collapsed to 2D image) (Each energy group colla)psed to create a 1D
curve
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# Vislt User Manual

Search docs

Docs » Using Vislt » B. Quantitative Analysis » 8.3. X Ray Image Query € Edit on GitHub

Documentation 8.3. X Ray Image Query

Getting Help + Introduction

Intro to Viskt + Query Arguments

o Standard Arguments

= Using Vislt
» Output Filenames and Directories
1. The Main Window
= Qutput Types

= Everything discussed today concerning 2 W D

3. Plots o Camera Specification
» Simplified Camera Specification

the X Ray Image Query and the Conduit o

> Calling the Query
6. Visualization Windows

Blueprint output from it is extensively Nt

. . B 8. Quantitative Analysis > Why Conduit Output?
documented in the Vislt Manual: iy
https://visit-sphinx-github-user- s Qe

= Query Parameters

manual.readthedocs.io/en/develop/using visit/Quanti 832 QueryArurmers o

8.3.3. Examples

> Imaging Planes and Rays Meshes

tative/XRaylmageQuery.html 34, ot utput g Planes

8.4. Pick = Rays Meshes
8.5. Lineout > Spatial Extents Meshes
° . . 8.6. LineSampler > Pitfalls
" > Visualizing h Visl
= These docs include descriptions of every e
9. Making it pretty = Visualizing the Imaging Planes

part of the output, how to visualize each

» Visualizing the Spatial Extents Meshes

11. Interactive Tools - 0
o Introspecting with Python

part with Vislt, how to digest the output 12 Ml Ot

» Accessing the Basic Mesh Output Data
1 Qe » Accessing the Metadata

with Python, troubleshooting, potential

15. Command Window » Accessing Everything Else
L]
= Troubleshooting
m 16. Preferences
pltfa | |S’ a nd Ore- 17, Help = |s my image blank?

» Why is my image blank?

Python Scripting

» Where are the rays intersecting my geometry?
Tutorials » What information is the query using to create the output?

Java Client s The fields in the Conduit Qutput are 1D. How can | reshape them to be 3D?

Lawrence Livermore National Laboratory N AVSE."_“% 18
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We are working towards ray tracer agnostic workflows to
support a wider set of tools

Simulation : \\
Mgsh Outpqts Any Ray Conduit
» (with Absorbtivity > Tracer »Blueprint Output
and Emissivity Files
fields) _
K "/ . / \\\ ///

= We want to make a clear split between ray tracing and simulating a specific detector.

= There are lots of tools; we want them to standardize on Blueprint input and output to enable
a modular capability.

= Part of this plan will be supporting this same feature set to Ascent for in situ use.
— It will mirror Vislt’s support and provide Blueprint output with the same meshes and metadata.
— The ray trace in Ascent will be GPU accelerated.
— There are low-order and high-order ray tracing paths, both need development work to support
multiple energy groups.

l Lawrence Livermore National Laboratory N AVS{&_‘% 19
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Summary

= Simulations and Experiments work hand in hand to enable High Energy Density Physics
Research, like the recent fusion breakthrough at the NIF.

= The Vislt X Ray Image Query is a part of a larger workflow for simulating diagnostics used in
NIF experiments.

= We have worked to enhance the output of the query by providing the option to output
Conduit Blueprint files.

= Conduit Blueprint provides far richer output that is easy to visualize in Vislt, easy to digest
with Python, and also makes it much easier to understand what the query is doing.

= This work is part of a larger effort to standardize Conduit Blueprint output from ray tracers
used in this kind of workflow.

. . \ "‘l
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