Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 38 lines (33 sloc) 1.6 kb
98b891e Damien White Added gemspec and jeweler
authored
1 # -*- encoding: utf-8 -*-
ad250bc Damien White Removed Jeweler for gem creation and used bundler instead
authored
2 $:.push File.expand_path("../lib", __FILE__)
3 require "ruby_odata/version"
98b891e Damien White Added gemspec and jeweler
authored
4
5 Gem::Specification.new do |s|
ad250bc Damien White Removed Jeweler for gem creation and used bundler instead
authored
6 s.name = "ruby_odata"
7 s.version = OData::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ["Damien White"]
10 s.email = ["damien.white@visoftinc.com"]
11 s.homepage = %q{http://github.com/visoft/ruby_odata}
12 s.summary = %q{Ruby consumer of OData services.}
98b891e Damien White Added gemspec and jeweler
authored
13 s.description = %q{An OData Client Library for Ruby. Use this to interact with OData services}
14
ad250bc Damien White Removed Jeweler for gem creation and used bundler instead
authored
15 s.rubyforge_project = "ruby-odata"
98b891e Damien White Added gemspec and jeweler
authored
16
58413ae Damien White Updated gems and added guard for automatic testing
authored
17 s.add_dependency("i18n", "~> 0.6.0")
18 s.add_dependency("activesupport", ">= 3.0.0")
19 s.add_dependency("rest-client", ">= 1.5.1")
20 s.add_dependency("nokogiri", ">= 1.4.2")
21 s.add_dependency("backports", "~> 2.3.0")
22
e92bde6 Damien White Rake needs to be upgraded or Ruby 1.9.3 bombs
authored
23 s.add_development_dependency("rake", "0.9.2")
58413ae Damien White Updated gems and added guard for automatic testing
authored
24 s.add_development_dependency("rspec", "~> 2.11.0")
25 s.add_development_dependency("cucumber", "~> 1.2.1")
26 s.add_development_dependency("pickle", "~> 0.4.11")
27 s.add_development_dependency("machinist", "~> 2.0")
28 s.add_development_dependency("webmock", "~> 1.8.8")
29 s.add_development_dependency("guard", "~> 1.3.0")
30 s.add_development_dependency("guard-rspec", "~> 1.2.1")
31 s.add_development_dependency("guard-cucumber", "~> 1.2.0")
da202c1 Damien White Made testing faster with VCR
authored
32 s.add_development_dependency("vcr", "~> 2.2.4")
98b891e Damien White Added gemspec and jeweler
authored
33
ad250bc Damien White Removed Jeweler for gem creation and used bundler instead
authored
34 s.files = `git ls-files`.split("\n")
35 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
36 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
37 s.require_paths = ["lib"]
38 end
Something went wrong with that request. Please try again.